Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently returned to my college campus for classes and brought my desktop computer running 64 bit Arch Linux out of storage. After updating my packages with sudo pacman -Syu, I rebooted and began to have some strange problems. While I can still access web pages through chromium and uzbl, some other programs such as pacman, wget, and curl are now failing to work. I also fail to ping any websites outside of my school's local network (although all my friends report the same issue on their Windows computers, so this could be my school's doing). I've mainly done my testing through wget, so I recognize a couple errors now. The usual one I've been getting is as follows:

:: Synchronizing package databases...
--2011-09-08 17:28:59--  ftp://mirrors.kernel.org/archlinux/core/os/x86_64/core.db
           => `/var/lib/pacman/sync/core.db.part'
Resolving mirrors.kernel.org... failed: Name or service not known.
wget: unable to resolve host address `mirrors.kernel.org'

After doing hours upon hours of google searching, many similar problems can apparantly be fixed by forcing the use of IPv4. However, modifying pacman.conf to append -4 to the wget command only changes the error to:

--2011-09-08 17:36:56--  ftp://mirrors.kernel.org/archlinux/core/os/x86_64/core.db
           => `/var/lib/pacman/sync/core.db.part'
Resolving mirrors.kernel.org... failed: Temporary failure in name resolution.
wget: unable to resolve host address `mirrors.kernel.org'

I've tried countless changes and nothing has worked so far. I'll post up some config files below. One last thing to consider is that at my school (Rensselaer Polytechnic Institute), they have redesigned their internal network to be fully IPv6 compatible. I also don't know what other firewalls or restrictions they may put on us. However, I do have a laptop running on the same network with nearly identical configuration. It has no troubles at all, so something must be wrong with this computer.

/etc/hosts:

#
# /etc/hosts: static lookup table for host names
#

#<ip-address>   <hostname.domain.org>   <hostname>
127.0.0.1       localhost.localdomain   localhost austonst-archlinux
::1             localhost.localdomain   localhost

# End of file

/etc/resolv.conf:

# Generated by dhcpcd from eth0
# /etc/resolv.conf.head can replace this line
domain dynamic.rpi.edu
nameserver 128.113.28.67
nameserver 128.113.26.77
# /etc/resolv.conf.tail can replace this line

/etc/rc.conf (Relevant part):

interface=eth0
address=
netmask=
broadcast=
gateway=

/etc/nsswitch.conf (Relevant part):

hosts: files dns
networks: files

route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         128.113.192.254 0.0.0.0         UG    202    0        0 eth0
128.113.192.0   0.0.0.0         255.255.240.0   U     202    0        0 eth0
share|improve this question
2  
kernel.org is down because of the security breach... does using a different mirror help? –  frabjous Sep 8 '11 at 21:55
    
Well, herp de derp. One of the first things I did when pacman was failing to work was use the online generator to make a new mirrorlist. It happened to be a fairly limited mirrorlist, but I didn't think there was any way that could be the problem. I even heard rumors here and there about the security breach but didn't consider that either. Everything's good now; thank you very much. –  Austonst Sep 9 '11 at 3:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.