Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a Windows XP SP3 machine. My Z: drive is a mapped drive to a UNIX box. There is a file called wk1_dailybackup_20110605043344.sql in both z:\archive and c:\archive.

At my CMD prompt from c:\archive the command

c:\archive dir *backup* 

lists my file, but when I go to z:\archive and type

z:\archive dir *backup* 

my file is not listed.


Questions:

  1. Why do wildcards not work on the mapped drive like it does on the local drive?
  2. What can I do to use wildcards on the mapped drive?

(Please don't suggest 'right-click Start, Search' to get the Poster Dog for inept searches.)

share|improve this question
    
What happens if you type: dir c:\archive\*backup* and dir z:\archive\*backup* n.b. these can be run from anywhere. –  Windos Sep 8 '11 at 22:13
2  
Maybe it has a hidden or system attribute set. Try dir /a z:\archive\*backup* –  Synetech Sep 8 '11 at 22:16
    
Do you see the same problem with dir *backup*.*? –  Jonas Heidelberg Sep 8 '11 at 22:19
    
Are you sure there is no typo anywhere (in the filename or in the commands you type)? How did you verify that the file actually is there in both locations? Do you see it when typing just dir in either directory? –  Jonas Heidelberg Sep 8 '11 at 22:20
1  
@Jonas, typos are irrelevant with a wildcard, that’s part of their use in the first place. Unless the word backup is misspelled (eg “bakup”), then it’s unlikely to be the problem. –  Synetech Sep 8 '11 at 22:22

1 Answer 1

In Windows NT, processing wildcard directory searches is the province of the individual filesystem driver. In the case of a remote volume, it is the province of the client FSD for the network, which may or may not it its turn hand search requests over to the fileserver.

Without anything more than "It's a UNIX box.", which doesn't even narrow things down to one FSD on the client, let alone provide information about the fileserver, no-one can tell you anything more specific than that your network FSD, or possibly the fileserver that it is talking to, has decided that wk1_dailybackup_20110605043344.sql will not come up in a wildcard search for *backup*. For all that the rest of us know, you're using network software that has wildcard processing behaviour as a configurable option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.