Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows Virtual PC running XP Mode.

On a current local user <Mark> I have put the PC on a domain <mydomain>.

Virtual PC works but I struggle to get the image I have working on the domain profile. I can create a new image and it works but getting the image that is in ./<mark> to work on <mark.mydomain> is the issue

I have used the Add a virtual hard disk step of the virtual machine setup, selected Use an existing virtual hard disk and then clicked the Browse button. I located and selected the Windows XP Mode base.vhd file that I was modifying earlier, which is located in the C:\Program Files\Windows XP Mode\ folder.

I say modifying earlier because I have changed the ownership and permissions and Windows XP Mode base.vhd and selected properties. To remove the read-only attribute that is preventing us from modifying this file, by Clicking the Security tab and then click the Advanced button.

Have I missed something? When I run using this .VHD the system creates a new image. Is it not the .vhd file that holds the old image from <mark> user, or is there a registration or config file that goes with this file to make the old image work?

I can still run the original image as the ./ user.

share|improve this question

migrated from stackoverflow.com Sep 8 '11 at 23:19

This question came from our site for professional and enthusiast programmers.

1  
This is not a programming question. You'd have better luck on SuperUser. –  Karmic Coder Sep 8 '11 at 23:15
add comment

2 Answers

up vote 1 down vote accepted

The VHD you were targetting isn't the same VHD you built under the domain profile.

The VHD under Program Files is a image Virtual PC uses to build a working XP installation.

Your domain profile's XP Mode VHD is under %UserProfiles%\Virtual Machines.

share|improve this answer
add comment

The answer is the file is hidden in local/app folder and you can then mount once copied to new profile.. found local/app folder as there are the default VHD and local VHD

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.