Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was working on a program in Eclipse. I went to run it, and ran into some 'unknown source' errors, so I tried to reinstall my java and ran into some annoying errors. First thing I ran into was an error saying that Z: is an invalid drive during the uninstall of the JRE.

I used to have a Z partition on my drive with some stuff installed to it, but that has since been changed. I tried again, and ran into a 1723 error, which from what I've found is a problem with the Windows Installer. I'm running Windows 7 and haven't found anything so I can reinstall it. I ran into the same 1723 error when trying to install java over top of the failed uninstall. Any ideas?

share|improve this question
add comment

2 Answers 2

I had a similar problem on my Windows 7 box where I was trying to uninstall Java and do a clean install of a newer version. Something got messed up and I would get the 1723 error message during the uninstall and attempted reinstall. Here's information about how I was able to fix the problem, and maybe this will help you:

Look at the log files for the uninstall/reinstall. On Windows 7 they can be found at c:\users\username\AppData\Local\Temp\

The java_install.logdidn't show any extra information, but I had several MSI##### log files that contained error messages about the failed uninstall. The message was: Error 1723.There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor. Action UninstallJRE, entry: MSIUninstallJRE, library: C:\Program Files\Java\jre6\bin\regutils.dll

There was indeed no regutils.dll file, and not even the bindirectory was there. So I copied over a regutils.dll file from another computer, ran the uninstaller, and it worked. Then the new clean install of Java also worked.

So take a look at your logfiles and hopefully that will give you more detailed information about the 1723 error.

share|improve this answer
    
Thanks this has been driving me nuts for months! –  slm Jan 31 '12 at 16:22
    
To complete this answer: These logfiles will be written into the path %USERS%\AppData\Local\Temp –  reporter Apr 17 '13 at 11:19
add comment

I ran into the same situation and I could find another way to solve this issue.

I downloaded the offline version from JRE6 and did install this - with default preferences- first. After that I installed the offline JDK version, also with default preferences. When I got the a positiv feedback from installer, I deinstalled both versions and installed the pure JDK in a folder of my choice.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.