Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm getting this message - You don't have permissions to save in this folder - even though I am the only user on this machine, and administrator.

How can I set permissions for myself to do everything, everywhere (including saving deleting etc)?

Edit: Sorry, forgot to say which folder it was. It is a folder in Program Files, where I save my PHP files for local testing.

Sorry if Im a bit daft with all this, but I've upgraded straight from XP to 7, and having never used vista, I'm used to being allowed to have full control.

share|improve this question
    
Which folder is that, by the way ? Some random folder, or something linked to the system ? –  Gnoupi Sep 1 '09 at 5:23
4  
Why are you saving your php files in your program files folder anyways? I would never ever do that... I would have them in a folder on separate drive (or at least partition) in case I managed to crash my OS. If it is because you have some sort of Apache installation living there with a certain web root folder, that can always be changed to something else. –  Svish Sep 1 '09 at 6:07
    
I have the same problem in Vista –  The Green Frog Sep 1 '09 at 7:52
add comment

5 Answers

This is due to UAC (User Access/Account Control) On Windows Vista / 7, and trying to write to a protected folder.

Typically Windows 7 has much lower UAC, but it is still there, especially with older programs that are trying to write to places.

You need to not double click on a file to open, but right click on the program that it opens up in, and click "Run as Administrator", for example to launch command prompt.

alt text

When you save, you should be able to write to almost anywhere.

share|improve this answer
1  
Well, thats a pain in the ass. –  James Sep 1 '09 at 5:31
2  
Yes, it's an equivalent to the "sudo" system under linux. Even if logged as an "administrator", you need to give administrator privileges to programs who write in "sensitive" places. However, this (UAC) can be fully deactivated, for a behavior close to XP, if that bothers you much. On the detriment of security, of course. –  Gnoupi Sep 1 '09 at 5:37
    
What is the File / Program you are trying to open, I may be able to find a better solution for you. –  William Hilsum Sep 1 '09 at 5:46
    
I would not turn off UAC if I were you. –  Corporate Geek Jan 10 '12 at 18:53
add comment

I would get out of the habit of manually creating files in the "Program Files" folder. The purpose of that location is to hold static application files. You can force the files there by changing permissions on the folder or accepting the UAC prompt when doing a manual copy but if your application expects to change data there you have to elevate privileges. See http://stackoverflow.com/questions/946420/allow-access-permission-to-write-in-program-files-of-windows-7 for a good discussion of this.

share|improve this answer
1  
Excellent answer, I was about to say the same thing myself. Non-elevated applications that interact there are redirected to the user's virtual store‌​, a brilliant feature which makes a great deal of sense for security and centralized yet individual user configurations. –  Christopher Galpin Dec 21 '10 at 11:15
add comment

To save file to a Program Folder in Windows 7, you will need to right click the folder whewre you want to save --> Properties, then go to the Security tab, highlight "Users" and then click "Edit..." Give it full control and apply, back out the windows and you should be able to save. When you are done, be sure to go back and uncheck the full control and write boxes.

share|improve this answer
add comment

Right click the folder, click properties, open security tab, edit the users (or your computer name) tick the modify(I tick all).

It works, I also use php and save it to htdocs, it works without the need of running as admin, which wont do to folders

share|improve this answer
add comment

This appears when you do not have enough permissions to write to this folder without your administrative credentials (given to you by UAC).

You can right-click on that folder and select Permissions. Then go to Security tab. Once you are there, you will see that Users have only read rights. Change that to Full access and Windows will not complain anymore.

share|improve this answer
add comment

protected by Diago Dec 21 '10 at 11:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?