Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a problem with a computer running Windows 7 on our domain. This computer will not run internet Explorer correctly, for example using citrix addon.

Also when I tried installing .exe's they would give an error 2349. Another thing is when I download an exe from Internet Explorer 9, they would be .exe but cannot be run and not shown as executable but as file. If I run exes as Administrator or internet Explorer as Administrator, they work as intended. Any ideas?

share|improve this question
    
Open Registry Editor as that user and check whether HKCU\Software\Classes\.exe and HKCU\Software\Classes\exefile exist; if yes, delete them. (Be careful -- don't confuse it with the system-wide HKLM\Software\Classes.) –  grawity Sep 9 '11 at 13:03
    
"This computer will not run internet explorer correctly, for example using citrix add-on" Can you please give us some details on what doesn't work? –  uSlackr Sep 9 '11 at 13:22

2 Answers 2

Sounds like there are some good security restrictions in place. This may be expected security behavior.

share|improve this answer

Agreeing with uSlackr, it sounds as if Windows is (correctly) configured so that non-Admin users can't install software or run untrusted (downloaded) binaries. Again, this is correct behavior, not a problem. You should install software only as Admin, and only after taking due care.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.