Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on a company computer with Windows 7 installed on it. I installed VirtualBox on it too and installed Ubuntu on this virtual machine.

Now from inside the virtual machine (Ubuntu), I can access the company's internal websites and I receive replies to my pings to the DNS, gateway, and DHCP servers but I still cannot ping anything outside or access the internet from the web browser.

My configuration is as follows:

  • On the host machine, there is one main ethernet adapter and one other host-adapter installed by virtual box. I have the host-adapter on default settings.
  • On my guest machine, I only have one ethernet adapter set to default.

I have tried just about everything I could think of.

share|improve this question
what happens when ping ext. IP - or – jet Sep 9 '11 at 15:35
I don't get any times out. – mtahmed Sep 9 '11 at 16:04
@mtahmed, How is the network of the VM configured? In NAT or Bridged mode? – jeffgao Sep 9 '11 at 17:07
I tried both NAT and bridged...on NAT, the network activity indicator (the one showed by VBox) doesn't show any incoming traffic (no green blinking light). On bridged it does. Although the problem is exactly the same with both configs. – mtahmed Sep 9 '11 at 17:11
You may be missing proxy settings, or your Ubuntu IP is not permitted outside the firewall. It could be anything. – user3463 Sep 9 '11 at 17:33
up vote 0 down vote accepted

If you are on corporate network (like I was), it is most likely that you are missing proxy settings. In that case, set the interface to NAT mode and then set the proxy settings as follows:

echo 'http_proxy=http://<my-corporate-proxy>:<proxy-port/' >> /etc/environment
echo 'https_proxy=https://<my-corporate-proxy>:<proxy-port/' >> /etc/environment

And so on for all the proxy settings. If that doesn't work use either the ~/.profile or the ~/.bashrc files to export these proxy settings.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .