Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How do you disable the window switch animation when switching spaces with Mission Control?

Is there a way in Mac OS X to turn off the animation you see when switching Spaces?

share|improve this question
    
add comment

migrated from stackoverflow.com Sep 9 '11 at 19:15

This question came from our site for professional and enthusiast programmers.

marked as duplicate by studiohack Sep 9 '11 at 21:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 3 down vote accepted

You can't disable the spaces animation in Lion.

What you can do is change the speed:

defaults write com.apple.dock expose-animation-duration -int 0; killall Dock

To revert that:

defaults delete com.apple.dock expose-animation-duration; killall Dock

Just copy and paste those into Terminal to run those commands.

Read more about this here on AD.

share|improve this answer
add comment

I believe what you are looking for may be in 10.6: Disable Spaces workspace change animation Desktop.

share|improve this answer
2  
I tested that in Lion and it didn't work. Maybe it only works for previous versions of OSX? –  ram1 Sep 9 '11 at 19:13
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.