Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been through several graphics cards (3 Radeon 5870s and a 6950) in the last six months and they all have been acting defective. The last three have been producing a lot of artifacts, both in games and outside of games, even after the manufacturer assured me that they had passed their diagnostic tests, so I've been running a GPU memory test (MemtestCL) and it frequently finds memory errors. I have a well-rated XFX power supply that should be providing more than enough power for these cards, and I'm running them all at stock clocks. I've tried testing with different motherboards, memory, and power supplies to no avail. Oddly enough my old Radeon 4850 hasn't shown any problems like this.

I am starting to suspect that there is something wrong with my environment that is causing these cards to fail. Is it possible that my PC isn't drawing enough power from the outlet? Or could there be something in my case that is frying the video RAM?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Visual artifacts can be caused by an overheating graphics card. Check your graphics card temperature with a tool like GPU-Z. If the GPU is overheating, make sure the GPU fan is hooked up to its power connector. You might have to remove the heatsink and re-attach it after applying a thin layer of thermal paste. Depending on airflow within your case you might need to redirect some air toward the graphics card.

Damaged GPU RAM can cause artifacts. When handling the graphics card, or any computer component, make sure you practice anti-static procedures. Ground yourself before touching any card to drain any static electricity that may have built up when you walked across the carpet or pet the kitty, and keep yourself grounded while handling the card. Try to hold the card by its edges and avoid touching any chips or metal parts of the card. Although it's possible to successfully install a card in the computer without being grounded, all it takes is one little zap and you've fried the GPU RAM or something else inside the case.

Make sure you have the power connectors hooked up correctly to the graphics card. Some cards require one or two power connections.

share|improve this answer
    
Thanks! GPU-Z is reading 38-45 degrees C. How hot is generally "too hot" for a GPU? I don't think static is my problem -- I haven't been using an anti-static wristband or anything, but I'm pretty careful with the cards and it seems unlikely that I would have zapped four of them in a row. –  mrohlf Sep 10 '11 at 0:10
    
That temperature seems pretty good so heat is probably not a problem. However make sure you measure the temp while it's actively artifacting, not when idle, as the temp can vary widely. I had a card once that would artifact when it got to around 90C or so. The next thing I can think of is to update your video driver, but I'm not so sure that will have an effect. –  cantfork Sep 10 '11 at 0:25
    
That's the strange thing, it seems to artifact more noticeably when I'm idle at the desktop than when I'm in games or anything. It's mostly a lot of little clusters of pixels that are off-color. I'll try upgrading my drivers -- they're fairly current, but I think I'll try running Driver Sweeper to flush everything out before I install the newest drivers. –  mrohlf Sep 10 '11 at 0:47

Do you have sufficient cooling in the case? I was working on someones computer a month or two ago - it was a big case, but only had fans on the CPU and the bottom of the PSU. The system had a 6950 and had the same issues, we took the side off and laid the computer on it side and benchmarked. The system did not produce the issue so I installed a 120mm in the back of the case above the graphics card and the issue has not occurred since.

share|improve this answer
    
I think it's cooling everything fine. Sensor readings have been at reasonable levels, and I've been running with the case open and it still artifacts. I have a 120mm on the back and top, so I think those are handling the cooling pretty well. –  mrohlf Sep 10 '11 at 16:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.