Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem

For some reason my Radeon HD 5700 seems to suffer from FPS drops.

  • 600W power supply should be enough
  • The core temperature when the FPS dropped was ~53 C (127 F)

Graphics card temperature & usage measurements

The GPU utilization is constant at 38% during the FPS drop (its not always 38%, sometimes its 65% or 24%, or any random between 0-100 but its always constant). Can you explain what happens here? Is there any workaround or fix?

More info: CPU is a Pentium 4 3.40 Ghz, the game used for testing is the free version of Trackmania at default settings, but it happens even on the lowest resolution and quality settings.

update:

Solution

Thanks to Mokubai, the culprit has been found. It was the CPU overheating.

CPU & System temperature measurements

share|improve this question
    
Is the ATI driver is up to date? –  darking050 Sep 10 '11 at 18:09
    
Yes, curenly the latest 11.08 is on, but I have tested with older drivers too. –  gnidoc Sep 10 '11 at 18:13
add comment

1 Answer

up vote 4 down vote accepted

Have you looked at the CPU and motherboard temperatures during these performance drops? It could be that either your CPU or motherboard chipset are overheating and throttling back and so reducing performance.

You can check most temperature sensors using Speedfan

share|improve this answer
1  
You sir, are awesome and deserve a thousand upvotes –  gnidoc Sep 10 '11 at 19:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.