Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Widows 7 installed on C:. I have 4GB RAM on my laptop. I had installed Photoshop CS5 on D:. And I had set 5-8 GB for virtual memory on E:

Space on drives after above consideration:

  • 12 GB is free on C:
  • 16 GB is free on D:
  • 11 GB is free on E:

Now when I am opening Photoshop CS5, surprisingly, system shows only 135 mb free on C:. Thats why I am not able to work for a minute in photoshop. Before this, when i was having Windows XP, Photoshop was occupying around 3-4 GB on C:. But, at least, I was able to work.

Please suggest me some setting I can configure to run photoshop on my laptop.

In addition, On my desktop machine(with 2GB RAM) where i have 4GB space free on C:, Photoshop is occupying only 2-3 GB.Even though, it is panic, but at least I can crawl with photoshop on desktop machine.

share|improve this question
up vote 1 down vote accepted

To start, check how much RAM Photoshop is allowed to use.

Go to Edit > Preferences > Performance

Check the value for Let Photoshop Use

enter image description here

Here's are other things you can try:

  1. Reduce the number of history states (a.k.a. the number of Undo's you can do).
  2. Use a different scratch disk than the one where your base images are stored. Personally, I use my D: drive rather than C: (primary boot drive).
  3. Turn Font Preview off under Edit > Preferences > Type.
  4. Disable thumbnail previews in the Layers panel.
share|improve this answer
    
My sister has decreased its loading time by setting some pallates, brushes, presets etc to default. Now at least it is being open and i can edit small files. I'll try your suggestion too. – Amit Gupta Sep 13 '11 at 3:55
    
Steps 1 & 2 can be found under Edit > Preferences > Performance. Step 4 can be done by right-clicking the Layers panel. – Kaze Sep 13 '11 at 5:27
    
These steps may not account for the entire 12gb that goes missing from your drive, but this is sort of a recommended-steps-to-optimize-PS checklist. Normally, it includes the stuff your sister did, but I had assumed yours was a fresh install and didn't have any custom shapes, brushes, styles, patterns, swatches, etc. – Kaze Sep 13 '11 at 5:30
    
On my laptop, having fresh installation, was occupying 12GB. While on my desktop, not a fresh installation, was occupyping only 3GB on C:. After resetting brushes,presets etc it reduces around 500-600 mbs. – Amit Gupta Sep 13 '11 at 8:17

What do you need 12 GB of memory for? Trim down the page file a lot if your usage isn't that high.

Thats why I am not able to work for a minute in photoshop.

Have you troubleshooted why you are not able to work?

Please suggest me some setting I can configure to run photoshop on my laptop.

If it is disk trashing, running out of space or your computer doesn't hit a requirement; there is no magic.

share|improve this answer
    
Would love to see some constructive advice on that down vote... – Tom Wijsman Sep 11 '11 at 12:03
    
can you suggest me how to troubleshoot? Moreover, I am not running any application in parallel. Then why photoshop is taking 12 GB space on C: – Amit Gupta Sep 11 '11 at 12:20
1  
@articlestack: Have you checked the requirements at Adobe? Also see Kaze's suggestion, although that doesn't count up for 12 GB. Perhaps, try Space Sniffer... – Tom Wijsman Sep 11 '11 at 16:17
    
Thanks for the tool. I'll try it today itself. and'll let you know. – Amit Gupta Sep 13 '11 at 3:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .