Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Mac mini with Snow Leopard installed. It have a blue tooth keyboard. This keyboard is a Swiss-German keyboard with all the necessary special characters on it. I have two problems with this keyboard:

  1. No matter what I do, it always acts as an US keyboard. The layout is wrong, X and Y are swapped and a lot of other characters are wrong placed. If I show the keyboard layout, it has an US in the title bar.
  2. If I try to configure the key board I click on "Configure blue tooth keyboard" in the keyboard configuration. The Mac never finds the keyboard although I can use it (with the wrong layout)

Any ideas?

share|improve this question
1  
Have you tried selecting the correct layout in Language & Text » Input Sources in System Preferences, then selecting it in the Input menu (the one showing the flag)? –  Daniel Beck Sep 11 '11 at 17:29
    
Thanks! That solved the problem. –  BetaRide Sep 11 '11 at 17:33
add comment

1 Answer

up vote 0 down vote accepted

Going on what Daniel Beck said in the comments, in System Preferences (language and text -> input sources) you tell OS X what your keyboard layout is (what keys yield what characters).

For example, I have mine set to french in this screenshot, and when I type, instead of "qwerty" it's "azerty." I think this is what you're looking for.

enter image description here

share|improve this answer
    
At least provide some additional value in the answer ;) –  Daniel Beck Sep 12 '11 at 11:33
    
Ah, I thought the picture was value enough. –  Vervious Sep 12 '11 at 23:59
    
There's an important note to this: As you can see from superuser.com/questions/338632/… you have to set the keyboard layout for the login screen in a second step. –  BetaRide Sep 23 '11 at 13:28
    
@BetaRide That's only for the login screen - maybe not everyone wants to login with a german keyboard. But you're right, that's another thing to change if needed. –  Vervious Sep 24 '11 at 1:05
    
To change the login language, you have to re-run the setup assistant. To do so, log in as an admin user and run (from the terminal): sudo rm /var/db/.AppleSetupDone; sudo "/System/Library/CoreServices/Setup Assistant.app/Contents/MacOS/Setup Assistant" –  Noah Apr 11 '13 at 7:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.