Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu(10.04.3 64bit server) guest VM on an ubuntu(11.04 64bit desktop) host.
The guest VM defaulted to the first network adapter as NAT. Now I want to enable bridged mode, but every other configuration besides NAT freezes the VM in startup.

Ive tried giving virtualbox SU-privileges but the problem persisted.

any tips or tricks?

Screenshot:Vbox Freeze

After a few minutes, the manager starts displaying the following: enter image description here

From here on nothing happens, the VM itself is frozen and cannot be closed, the vm managed can be closed but 2 processes stay open which prevent it from being opened again, I assume the problem lies within these processes:
VBoxSVC & VBoxXPCOMIPCD enter image description here

Log file content(last few lines of log):

00:00:00.555 VDInit finished
00:00:00.555 AIOMgr: Endpoint for file '/home/madmaze/VirtualBox VMs/redmine/redmine.vdi' (flags 000c0723) created successfully
00:00:00.566 AHCI: LUN#0: disk, PCHS=16383/16/63, total number of sectors 16777216
00:00:00.567 AHCI: LUN#0: using async I/O
00:00:00.567 AHCI ATA: LUN#0: disk, PCHS=16383/16/63, total number of sectors 16777216
00:00:00.567 AHCI ATA: LUN#1: no unit
00:00:00.567 AHCI ATA: Ctl: finished processing RESET
00:00:00.567 AHCI ATA: LUN#2: no unit
00:00:00.567 AHCI ATA: LUN#3: no unit
00:00:00.567 AHCI ATA: Ctl: finished processing RESET
00:00:00.567 AHCI ATA: Ctl: finished processing RESET
00:00:00.567 AHCI ATA: Ctl: finished processing RESET
00:00:00.567 PIIX3 ATA: LUN#0: no unit
00:00:00.567 PIIX3 ATA: LUN#1: no unit
00:00:00.567 DrvBlock: Flushes will be ignored
00:00:00.567 DrvBlock: Async flushes will be passed to the disk
00:00:00.568 PIIX3 ATA: LUN#2: CD/DVD, total number of sectors 0, passthrough disabled
00:00:00.568 PIIX3 ATA: LUN#3: no unit
00:00:00.568 PIIX3 ATA: Ctl#0: finished processing RESET
00:00:00.568 PIIX3 ATA: Ctl#1: finished processing RESET
00:00:00.579 New value of somaxconn: 1
00:00:00.579 NAT: value of BindIP has been ignored
00:00:00.579 IntNet#0: szNetwork={HostInterfaceNetworking-eth0} enmTrunkType=3 szTrunk={eth0} fFlags=0x8000 cbRecv=325632 cbSend=196608 fIgnoreConnectFailure=false
share|improve this question
    
Try opening up VirtualBox, editing the setting from NAT to bridged, saving the settings, and then closing VirtualBox completely. Then re-launch VB and see if the setting persists or is reset to NAT. That might give a clue as to if the configuration change is actually being saved or not, and might help isolate the cause. –  sbtkd85 Sep 12 '11 at 16:44
    
I can confirm that the settings are being saved, I changed it, saved, closed, opened and checked. And settings persisted –  madmaze Sep 12 '11 at 16:48
    
Do the Zombie processes shown in your screenshot keep running after you close VirtualBox completely? If they keep running it may be worth it to try a restart on the host. –  sbtkd85 Sep 12 '11 at 17:08
    
yes they do, and ive tried restarts as well but no change. –  madmaze Sep 12 '11 at 19:03
    
So i have eliminated the guest as the problem, any VM I start, only starts successfully if I have NAT selected –  madmaze Sep 12 '11 at 19:16

2 Answers 2

Sounds like you need to recompile your VirtualBox kernel module to me.

share|improve this answer

I ran into the same scenario, using Ubuntu 64 Bit and many guests, all were working with no problems, until I started to do a lot of things with qemu.

I recall I inserted the kvm and kvm_intel modules.

  • I could fix it by removing them using rmmod or modprobe -r.
  • Another workaround was to unload the vboxnetflt module and reinstalling VirtualBox, but the first was the key.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.