Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For no apparent rhyme or reason Vista will decide to show a folder that was previously in details view to start showing thumbnails. I go to the folder and right-click, Customize, and set it the template to "All Items", and "Also apply this template to all sub-folders", but it some point it will again decide to display it as thumbnails. Is there a way to force this setting to stay, or is it that possibly something is changing it that I am not aware of?

share|improve this question
    
Oh, I will follow this one. For some reason Vista has decided that nearly every folder in my computer contains images and videos. They don't. –  Fredrik Mörk Jul 15 '09 at 19:09
3  
I also love when a random "group by" gets applied for no apparent reason. I'm going with "bug" (because it has yet to happen to me in Windows 7), but we will see. –  JP Alioto Jul 15 '09 at 19:12
    
This has happened to me with both XP and Vista. –  Daniel F. Thornton Jul 15 '09 at 19:29
    
All I could think off is your own suggestion... –  Ivo Flipse Jul 15 '09 at 20:10

2 Answers 2

up vote 6 down vote accepted

There seems to be multiple things that might cause this as an issue, and multiple resolutions as well, hopefully solving or making this "bug" appear less frequently.

  1. Manually resetting the folder view cache/settings
    1. Start regedit. (Win+R, enter regedit, press Enter or click OK. )
    2. Browse to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell.
    3. Delete the keys Bags and BagMRU.
    4. Browse to HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell, repeat step 3.
    5. Browse to HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam, repeat step 3.

Trying some of these additional tweaks might help, mix it with it and see what you get.

  • Disabling automatic folder type discovery
    1. Browse to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell in regedit.
    2. Create a new key under Shell, called Bags.
    3. Create a new key under Bags, called AllFolders.
    4. Create a new key under AllFolders, called Shell.
    5. Create a new string value under Shell, called FolderType.
    6. Set the string value of FolderType to NotSpecified.

You can increase the size of the folder view cache as well.

  • Increasing the size of the folder view cache

    1. Browse to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell.
    2. Set the DWORD value of BagMRU size to something higher than 5000.
      • Note: If it's not there, create it.
  • After resetting the cache/settings + apply tweaks

    1. Log off/on or reboot.
    2. Open a Windows Explorer window and go to the Folder Options window.
      1. Select the View tab.
      2. Check Remember each folder's view settings.
      3. Uncheck Restore previous folder windows at logon.
      4. Hit the OK!

This should do it, or rather, perhaps improve the experience. Nevertheless, using an application as CCleaner with the wrong settings can disrupt and delete your settings, so be aware and checking before you use applications focused on "cleaning up".

share|improve this answer

I had this issue until I disabled UAC. It seemed it took administrator privileges to save the view setting.

I admit I tried no other solutions, so perhaps there's a better (more secure?) remedy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.