Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On (rhel5/centos5) Is there an easy way to either turn off the vino icon that appears at the bottom of the screen when someone connects, or leave it displayed but disable the ability to enter the vino preferences from it ?

Need to be able to do this remotely.

I thought gconf's /desktop/gnome/remote_access/icon_visibility would do it, but it appears that vino at least ignores that (at least, when it's set to "always" the icon isn't always shown so i'm assuming that it's being ignored)

is the /desktop/gnome/remote_access section actually where vino uses ?

share|improve this question
add comment

1 Answer

That might be a bug with vino not working properly, Not always displaying. I expect it is probably only showing when a connection is initiated. After which it will continue to display. So it will initialize itself after it is connected to the first time.

You were almost correct it should have been set to "never". I just tested it on 10.04 LTS. I used the gui tool and checked to see what chanages it made to gconfig. The gconf-editor had this to say about it.

Long description: This key controls the behavior of the status icon. There are three options: "always" - The icon will be always there; "client" - You will see the icon only when there is someone connected, this is the default behavior; "never" - Never shows the icon.

To get it to do what you want I would use the never option.

$ gconftool --set /desktop/gnome/remote_access/icon_visibility --type string "never"

Check your setting is correct you should get out the value you set.

$ gconftool -g /desktop/gnome/remote_access/icon_visibility
never

That is the simplest way to stop people using the icon and getting to the preferences dialog. You would have to rewrite the icon widget they are using and recompile it to disable options it provides. If you are up for the browse the vino source.

share|improve this answer
    
its not being honoured. If i uncheck (with gconf-editor) the "enabled" checkbox it does indeed disable the ability to vncviewer in from outside so it is definitely using that particular gconf subdirectory, but setting icon_visibility to "never" either via your way or in gconf-editor the icon is still being shown, even after zapping xorg. Can you confirm this definitely works on your machine ? –  Sirex Sep 15 '11 at 11:30
1  
from my testing, it looks like icon_visibility does not exist on redhat 5 –  Sirex Sep 16 '11 at 10:47
    
no I can't confirm. I was looking at purely from the command line. I just peered into the config to see what was going on there. It defiantly seams like a bug. Maybe its time to try some other vnc server viewer combo like tight vnc. –  nelaar Sep 16 '11 at 12:44
    
sadly not an option as this is in the wild on 600+ client machines. I'll take it up with redhat and see what they say. Was also wondering if i could chattr +i the .gconf subdir or some other kludge to prevent the settings being altered. Not had any luck on that so far though. –  Sirex Sep 17 '11 at 3:57
1  
if it works on ubuntu and not redhat, it's probably a difference in the way it's compiled/installed/configured. barring differences in versions, you might have to repack your own RPM to more closely resemble the ubuntu LTS version that's working as you want. just a thought. –  hbdgaf Sep 20 '11 at 12:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.