Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just received a new laptop with a ghosted Windows 7 Professional image. When I go join the machine to the domain I see the 'Domain' text box greyed out (the system is in Spanish) :

Join domain dialogue box

My local account has administrator rights. To verify it's not my account that's at fault I've enabled the Administrator account and tried to join, logging in with that account, without any success. Does anyone know why that box is greyed out? The 'Network ID' button is also greyed out in the system properties dialogue box.

share|improve this question
    
Make sure your WIndows 7 in not HOME edition. It should be at least PRO –  user117467 Feb 8 '12 at 19:51
    
It was the Pro edition. In the end a re-install from DVD sorted out the problem. –  grantc Mar 8 '12 at 13:31
    
Check that the WORKSTATION service is started. –  user173635 Nov 15 '12 at 11:41
add comment

5 Answers 5

Check the Device Manager and make sure the network card is ok.

Also check to make sure the correct protocols are installed. Right Click the NIC and choose properties. "Client for Microsoft Network" etc should all be there.

You also want to check your Services. Computer Browser, WorkStation, Netlogon, etc should be running.

share|improve this answer
    
Starting the Net Login services gives the following in the event log - "This computer is configured as a member of a workgroup, not as a member of a domain. The Netlogon service does not need to run in this configuration.". All the other services you mention are started and the adapters (Wifi and ethernet) have the MS client installed. –  grantc Sep 13 '11 at 9:35
add comment

Steps to try:

  1. Do you have the correct DNS settings (the primary server should be a Windows AD DNS server).
  2. Is "Client for Microsoft Networks" listed on the network adapter properties?
  3. If you have access to the AD, add your computer first, then see if it lets you join.
share|improve this answer
    
1. appears to be ok 2. Yes it's there for both adapters 3. I don't have direct access to the PDC –  grantc Sep 13 '11 at 10:38
    
This has nothing to do with the DC. –  surfasb Sep 13 '11 at 13:55
add comment

Hmm, I thought for sure the "Computer Browsing Service" would be the culprit. Or even "Client for Microsoft Network". I would try unpluging the computer from the network and reboot, see if that will help. If not try changing the computer name. Some more things you could try:

Removing all instances of "WORKGROUP" from the registry

Seeing if there is some kind of hidden GPO preventing change

If none of that works, well poop, we'll have to find something outlandish to try! Good luck!

share|improve this answer
    
Changing the name had no effect, neither did removing references to "WORKGROUP" in the registry. I'll take a look at downloading the GPO tools to see if that sees anything. I have a suspicion that whoever built the ghost image has done something strange. Perhaps I'll need to rebuild from scratch. –  grantc Sep 16 '11 at 12:09
    
Yeah, if you can't find the source of the issue, and it's an uncommon one, you might just have to. I had a server one time that would NOT install AD. No matter what I tried. Spent three weeks to no avail. Reinstalled the OS and it worked fine. –  Duall Sep 16 '11 at 19:45
add comment
up vote 0 down vote accepted

It would appear that there was something wrong with the image used to ghost the machine from. A re-install from scratch using the DVD resolved the problem.

share|improve this answer
add comment

Had the same problem with Windows 7 Enterprise, and it was resolved by generating a new SID and changing the name of the PC to something new (I used NewSID for that).

share|improve this answer
1  
That's good to know, thanks. –  grantc Mar 21 '12 at 8:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.