Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The MacBook does not boot. The screen stays blank (black) – not the grey, active screen like normal. To power off, I hold the power button down.

After 5 boot attempts the MacBook finally shows the grey, active screen and boots OSX.

This started after I installed Ubuntu 11.04 on a 2nd partition.

Here is the sequence of events and my attempts to fix the problem:

  1. OS X on partition 1.
  2. rEFIt installed and set to appear on every boot – everything still working fine.
  3. Installed Ubuntu 11.04 on partition 2 – at the end it said Grub was installing on the hard-drive.
  4. MacBook, after shutdown, and restart sounds a long tone and has a blank (black), unlit screen (ie not grey/active). It does not boot or do anything. Holding Option key does not work. After 5 power cycles, the MacBook finally boots to OSX.
  5. I synced the partition table with rEFIt and shutdown.
  6. Same as step 4, after many reboots I can load rEFIt then OS X or Ubuntu.
  7. I ran rEFIt script to bless it again – result same as 4.
  8. I used OS X's Startup Disk utility to select OSX hard-drive – result same as 4.
  9. I then used OS X install-DVD to totally format hard-drive and re-installed OS X – result same as 4.
  10. Many more attempts of steps 5 to 9 – result same as 4.

Further details on number 4 (above):

Note, Option (AKA Alt) key works on a normal bootup, but it is after/outside my problem.

A "normal boot" can be described as:

  • OSX loads
  • or, holding Option key shows the EFI boot-selection
  • or, holding Command+Option+P+R keys resets NVRAM.

However, the problem I have is that "normal boot" fails for the first 5 power-cycles. (After a failed boot, I can kill power by holding the power-button down.) During failed boots, NOTHING works (no keys, no OSX) - just a blank screen.

Its like the EFI code crashes or freezes. But on the 5th power-cycle a "normal boot" always works, like some fail-safe is triggered. Then after I shutdown OSX, the boot issue repeats - ie another 5 power-cycles before I can get back to OSX.

Note, on the first (only the first) failed boot (one of five) (after shutdown) the MacBook Pro makes a tone (an error-tone I assume).

Here is my system:

  • Model Name: MacBook Pro
  • Model Identifier: MacBookPro5,4
  • Processor Name: Intel Core 2 Duo
  • Processor Speed: 2.53 GHz
  • Bus Speed: 1.07 GHz
  • Boot ROM Version: MBP53.00AC.B03
  • SMC Version (system): 1.49f2
share|improve this question
Please don't rollback edits - by rolling it back you're making it to a vague question which is likely to be closed. Thanks. – Sathya Sep 13 '11 at 10:17
I have the same problem this guy seems to have the answer lots of happy ubuntu/osx users in the comments… – user101153 Oct 12 '11 at 13:53

Try resetting the NVRAM and PRAM. See this Apple Support link.

It could also be a problem with the boot loader; try pressing Alt at boot time and select the OS X partition. If it boots directly w/o any problems you need to check on the boot loader.

For further information about Ubuntu on a MacBook you could also consider reading Installing Ubuntu on a MacBook.

share|improve this answer
Good suggestions, thanks Michael. Unfortunately, resetting the NVRAM and PRAM did not fix the problem. Also, I studied the "Installing Ubuntu on a MacBook" guide before starting, and have attempted all suggestions detailed there. – Reilly Beacom Sep 13 '11 at 10:04
Oh, sad it didn't help. What about the alternative boot? – Mose Sep 14 '11 at 12:04
Hi Michael - thanks for taking an interest in this. I have updated my question with more information about "alternate boot". I am wondering if I could/should find a way to revert the MacBook's firmware? There are CD-images available from the Apple website, but they claim to only work for upgrades (not reverting). – Reilly Beacom Sep 15 '11 at 6:04
PS, Michael, I can't vote up your answer (1 point for suggestions/discussion) because Im under 15 rep on SuperUser. I will sometime in the future! – Reilly Beacom Sep 15 '11 at 6:25
Never heared about rEFIt. I checked out their site and maybe it could be the problem in your situation. i dont know what rEFIt does exactly, but after EFI is in the name maybe it changes some in there. i never updated or changed macbook firmware... so i cant help here. sorry, but i wish you good luck :-) i think because the problem still exists after formating the HDD the boot loader can't be the problem anymore. – Mose Sep 15 '11 at 14:31

Having the same problem with my Macbook Pro. I've tried everything suggested here, but end up with the same 5 power boot before getting normal boot scenario. I hope that another user or Ubuntu Community would provide a solution for these problems, as for now my solution is: Do not Shut Down your system, just put it in Sleep mode. That would save you some trouble (for now).

share|improve this answer

The lack of a detailed description of the installation makes it unclear whether the hardware is booting in EFI mode or using the CSM. If the installation CD/DVD is inserted, the computer turned on, and you hold the option key to bring up the startup disk menu, if the CD icon is labeled "Windows" then it will enable CSM (BIOS emulation) boot and the installer will install a BIOS dependent bootloader. If the CD icon is labeled EFI Boot then that's EFI mode booting and the installer will install an EFI dependent bootloader: most likely grub.efi, on the EFI System partition.

On my Macbook Pro 4,1 I can only do EFI booting with text console. Nouveau and proprietary nvidia drivers hang graphics display upon enabling, although it's possible to ssh into the system and it functions fine otherwise. Using kernel parameter 'nomodeset' I can successfully boot text only and use the built-in display. According to the following bug, the nouveau developers are saying they cannot get the information needed from EFI mode booting, from Apple's EFI implementation. (Comment 34).

On my Macbook Pro 8,2 an EFI mode boot produces unusable text and graphics video and I have been unable to do any further testing.

With both hardware models, CSM mode boot functions pretty well outside of certain hardware driver availability and refinement. But it's not obvious how the user can know whether EFI mode or CSM mode boot is occurring. This is one reason why I decided to abandon rEFIt as I just couldn't really tell what was being booted or how, and it would present options for booting that simply wouldn't work.

To produce an linux distro installation that uses the CSM without depending on rEFIt requires some special handling to get Apple's EFI to enable the CSM. I've filed those in this bug.

Really we should lobby Apple for full UEFI 2.x support, instead of their current firmware which is still largely based on Intel EFI 1.10 (with some things from the UEFI spec). In my opinion it is unreasonable, even if it would be nice, to expect the linux distributions to support Apple's non-standard EFI implementation. So for now, I'm using the CSM, but I'm hopeful that Apple will get this sorted out.

For those using Lion, you will likely have a "Recovery HD" partition as your 3rd partition, so partitions 3, 4, and 5 in the bug above will be 4, 5, and 6.

share|improve this answer

The best way to fix boot problems with Ubuntu 14.04 final release.

With o without Ubuntu preinstall.

Works with Ubuntu 14.04 final Release

Press Power Button and Boot with MACOSX Installation DVD or USB.

Open terminal and paste the script:

bless --device /dev/disk0s1 --setBoot --legacy

And then reboot.

After 30 seconds, The grub 2.0 of Ubuntu boot, no problems.

Versión en español:

La mejor manera de corregir los problemas de booteo de una MacBook simple o PRO.

Con ubuntu ya instalado, corriendo solo NO dual boot.

Inicie la MacBook con un disco de instalación MACOSX o un USB Booteable.

Escoga el lenguaje y seguido Abra la terminal y ingrese el siguiente script.

bless --device /dev/disk0s1 --setBoot --legacy

Reinicie y espere 30 segundos, el Grub 2.0 de Ubuntu arranca sin problemas.

Saludes y suerte.

share|improve this answer

Just use efibootmgr -o 3,4,1 to change order.

More on details, check

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .