Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Google Chrome 13.0.782.220 on my Ubuntu 10.04 LTS (64-bit).

I try to edit a JavaScript code from an external JS file in the Chrome Developer Tools Scripts pane by double-clicking on the script area. No matter how fast I click, the only effect is to select a nearby word.

Does anybody have an idea why the edit mode isn't activated?

share|improve this question
    
I don't think there is a Javascript edit mode in Webkit Inspector. At best, you could use breakpoints, and trace your output. –  Capt.Nemo Sep 15 '11 at 12:30
    
As stated here (redirected from here it is possible. –  Rajish Sep 15 '11 at 12:36
1  
This comment states that "Unfortunately you cannot live-edit pretty-printed JS. Maybe that'll come later." Dated 16th May 2011, so its pretty recent –  Capt.Nemo Sep 15 '11 at 12:39
    
Yes, it does work with pretty print off. Chrome is awesome –  Capt.Nemo Sep 15 '11 at 12:40
    
@Capt.Nemo You hit the nail. Put it as the answer so I could award you with the bounty. –  Rajish Sep 18 '11 at 19:28
add comment

2 Answers

up vote 14 down vote accepted
+100

Chrome Webkit Inspector does not allow you to live-edit pretty printed Javascript. Click the pretty print button (Looks like { }) in the Scripts tab to disable pretty-print mode and edit it.

Source: Introduction To Chrome Developer Tools

share|improve this answer
add comment

You might have hit against the Same origin policy.

From Disabling cross-domain security check for AJAX development in Google Chrome :

Start Google Chrome from command line, Ubuntu/Linux:

chromium-browser --disable-web-security
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.