Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 11.04, with the / partition in an encrypted LVM volume. /home is in the same logical volume. I'm trying to use the LVM snapshot functionality to enable time-consistent backups of the running system.

I left over 500MB of unpartitioned space in the volume group, as I understand it needs that empty space for snapshot data. Whenever I try to create a snapshot, this is what happens:

$ sudo lvscan
  ACTIVE          '/dev/vgroup1/volume1' [10.62 GiB] inherit

$ sudo lvcreate -L400M -s -n snapit /dev/vgroup1/volume1
      The link /dev/vgroup1/snapit should had been created by udev but it was not found. Falling back to direct link creation.
      semid 589825: semop failed for cookie 0xd4d5c76: incorrect semaphore state
      Failed to set a proper state for notification semaphore identified by cookie value 223173750 (0xd4d5c76) to initialize waiting for incoming notifications.
      Logical volume "snapit" created

What am I doing wrong? Or is this an Ubuntu bug?

share|improve this question
    
It could be related to this bug... bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/719388 –  Mike Rowave Sep 13 '11 at 15:56
    
The snapshot seemed to work despite that error, but I am concerned about its integrity given the error. I'd prefer to eliminate that error if possible. –  Mike Rowave Sep 18 '11 at 16:06

1 Answer 1

up vote 0 down vote accepted

The error didn't happen when using the LVM GUI.

Upgrading to a newer kernel eliminated it altogether.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.