Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use an English (US) international keyboard layout, and every time I use the key ´ followed by c it yields the Portuguese and French character "ç" (cedilla), which is desirable. However in GTK apps (Pidgin for instance) it yields "ć", which is Polish.

How can I make GTK apps behave the same way as the rest of the apps do?

NOTE: I had the same problem on Ubuntu 11.04 and 10.10, and they found two sets of solutions that work on those specific versions.

share|improve this question
    
If you don't get a good answer here, I would recommend flagging your question and having it moved to unix.stackexchange.com. –  MaxMackie Sep 14 '11 at 2:09
1  
@Max I don't understand how a question about Windows would be helped there –  Jader Dias Sep 16 '11 at 17:39
    
Unless I missed it, "Windows" wasn't in the title before Gareth edited it. –  MaxMackie Sep 16 '11 at 17:59
    
@Max it was always there –  Jader Dias Sep 16 '11 at 18:07
    
I don't use GTK on Windows, but have you tried to search for a file named "gtk.immodules" ? If it exists, the above link you gave might still work. –  harrymc Sep 25 '11 at 7:22

1 Answer 1

up vote 2 down vote accepted
+50

The problem is that GTK apps do not integrate with the Windows input Method Editor (IME) language settings and instead use their own. By default this is set to Simple and needs to be changed. You need to create a new system-wide environment variable called GTK_IM_MODULE and set it to cedilla (I wrongly thought that when set to ime GTK would emulate Windows own behaviour but IME is a different thing). I got the name of the environment variable from here: http://developer.pidgin.im/ticket/4896

share|improve this answer
    
ime doesn't work exactly like windows ime. to make the cedilla work I had to use cedilla. Capitalizing it (Cedilla) didn't work. –  Jader Dias Sep 27 '11 at 19:55
    
Glad you got it working in the end. I updated my post to clarify my mistake. –  James Sep 28 '11 at 15:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.