Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is simple: If I set the webserver's IP address as my desktop's default gateway in TCP/IP settings, I cannot open any locally hosted site at our webserver on my PC. I can open any other site from the internet as well. If I use a real IP address then I can open our sites too.

The previous webserver was Windows Server 2003 Webserver Edition, and it had no problem like this. The newer one is Windows Server 2008 R2 Standart Edition.

All clues are now listed. If you need any info or got idea, I'll supply more on request.

Addition & correction a bit:

I cannot open any site if my IP is local. ie: webserver 192.168.35.211 mydesktop 192.168.35.45

  • I can telnet mysite.com 80 but there are no responses to my requests.
  • I can telnet mysite.com 25 and there is response.
  • VPN connection from home to Webserver makes the sites "offline" to me. I can still open supersuser.com thru Webserver

So I think there is IIS related problem instead of network.

share|improve this question
    
"I cannot open any locally hosted site at our webserver on my PC. I can open any other site from the internet as well." The 'as well' is confusing me... So, when the gateway is set the web server, you CANNOT access locally hosted sites, but you CAN access Internet sites? Are the local sites you can't access all on the Web server you have set as your gateway? Do the FQDN's resolve in via DNS? Have you tried accessing via both names and IP addresses? –  Ƭᴇcʜιᴇ007 Sep 13 '11 at 19:05
    
Yes exactly what you say. I can telnet mysite.com 80 but there is no response to my requests. I mean DNS is OK. If I set another machine/modem/line as my gateway I can open the sites -from public/WAN IP- I can't open the sites if my IP is local. –  Nime Cloud Sep 13 '11 at 19:19
    
What does Wireshark tell you? –  grawity Sep 13 '11 at 19:20
    
Now I learned there is a tool called Wireshark :) –  Nime Cloud Sep 13 '11 at 19:25
1  
you are setting your default GW to the IP of your webserver? Is your webserver also a router? Can you access new internet sites? Do you use a proxy server to access the internet? The default GW needs to be a router, not a web server.. –  Doon Sep 13 '11 at 19:52

1 Answer 1

What I think is happening is this. Please correct me if I am wrong.

mysite.com has public ip address

mysite.com get translated to internal IP address by your firewall to an internal RFC1918 address(192.168.35.211)

When you are on your local network you can access 192.168.35.211, but not mysite.com?

This is normal behavior as the firewall or device performing the Address translation cannot hairpin the traffic through it, so your packet go out, but they never come back in.

A normal way around this is to either use split horizon dns zone. IE inside mysite.com resolves to 192.168.35.211, outside it resolves to your public ip. Or you use the internal name (http://mysite.local/ or the like..)

The same thing happens on VPN, since you cannot access the public resources, since the default gateway is probably set on the vpn connection. Changing that is either up to your network admin (or if you have control, you can uncheck use default GW on remote network, and manually set routes to your office network).

But if my above assumptions are correct, your problem is network related and not IIS related.

share|improve this answer
    
I disabled ALL firewalls. In Routing & Remote Access (notice Server Standart) > WAN interface > NAT > Internet > With basic firewall checked> internet: ok / my sites > offline unchecked> internet: no access / my sites: online –  Nime Cloud Sep 13 '11 at 20:38
    
So you windows server has 2 interfaces? Lan and Wan, and is providing routing /address translation between the 2? what IP does mysite.com resolve to when you are local, and does it work via IP? –  Doon Sep 13 '11 at 20:45
    
Why other services -like SMTP- have no problem? –  Nime Cloud Sep 13 '11 at 20:46
    
I just tested; I can open https://mysite.com –  Nime Cloud Sep 14 '11 at 21:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.