Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old computer in my dorm room. It acts as a gateway and traffic-shaper (htb) for me and my roommates.

Debian is installed into it. It has been working quite good for a year. Nothing happened until Thursday. 2 days ago it started behaving unexpectedly.

We have 2 interfaces:

  • **eth0** - this one looks into local network.
  • **ppp0** - this one connects with internet.

We have configured NAT.

The strange fact here is that server suddenly becomes unreacheable.
ifconfig shows, that eth0 and ppp0 are both up.
But I can't ping server from my laptop as well as laptop from server.
But ppp0 works! I can ping google.com from server.

I execute
ifconfig eth0 down
eth0 and ppp0 go down. only lo is up. As expected

Then I
ifconfig eth0 up
Server becomes reachable.
Then I try to pon dsl-provider ... and it doesn't start PPPoE connection.

Only reboot makes it work... just for 5-7 minutes.

share|improve this question

migrated from serverfault.com Sep 13 '11 at 20:10

This question came from our site for professional system and network administrators.

add comment

2 Answers

What about replacing the server by a usual router?

If not: Do you use a RealTek-Interface (rtl8139 or similar)? I had some RealTek-Interfaces in the past that ceased to work like in your case.

Try to plug in a new network-card and then change your udev-settings after reboot (mac to eth - mapping).

What is your real setup of interfaces? eth0, eth1 and ppp0 using eth1?

share|improve this answer
add comment

If you're using ppp0 over eth0 and eth0 is the physical WAN interface, maybe you are "cut-off" by receiving one arp reply/gratuitous packet from your ISP network that match the gateway IP address from your NATed hosts (which are refreshing their arp table with the wrong one). It is common for ISPs to use the private address space inside their network (without advertising them). Look in your arp table from NATed clients and compare it with the one from eth0; if the hw addesses don't match just buy another NIC or set the arp as static.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.