Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This issue was brought up many times in different forums, with no real solution (try searching the Web, there are results starting from 2009).

After getting a laptop with Windows 7, I cannot access non-public FTP sites any more. Looks like it is a common problem, and I'm still convinced it is because of Win7. The Windows Firewall is disabled and I've tried many different connection points so this is not an issue of a router either. For the same connection points, a laptop with Windows Vista connects to the FTP just fine. A friend with a Win7 machine has also confirmed the same behaviour I experience: either the FTP client won't connect at all or after connecting, won't display the file list or allow any download/upload.

FTP clients checked: command line, Windows Explorer, FileZilla, Ipswitch WS_FTP, Cyberduck. Of all these, only Cyberduck shows successfully the file structure, however any transfers fail one way or another.

I'm really lost and need help, since I rely on those private FTP sites and need to access them from the Win7 machine...

share|improve this question
    
Are you using some form of anti-virus or malware program? –  MrStatic Sep 14 '11 at 2:54
    
A McAfee VirusScan Enterprise is running on the computer, however its "prevent FTP communication" setting is not set. –  interDist Sep 14 '11 at 4:02
    
try the filezilla forum and tell them a program called cyberduck can get further, they'll love that –  barlop Sep 15 '11 at 1:15
    
you need to find some error messages somehow.. and another method , s could take a while but how about looking with wireshark and seeing if you see any errors there, or why cyberduck is getting further.. but FTP is complicated. –  barlop Sep 15 '11 at 1:17
    
Why not try booting off a Linux livecd and see if FTP works. That would completely rule out any firewall/security/OS issues on your system. If it doesn't work off a livecd, then some thing outside your system is broken. If it does work, then you are probably need to try uninstalling and/or disabling security software. –  Zoredache Sep 15 '11 at 4:52

1 Answer 1

Odds are, you're behind a NAT firewall yourself, and it's possible Windows 7 changed a default involving ACTIVE/PASSIVE port settings.

If you're using ACTIVE port addresses for transfers, if you're behind a NAT firewall, it won't work, and you'll time-out on everything, directory listing, transfers, and so on. The only thing that works is the initial port 21 connection. (Any other transfers are negotiated and performed using another port/socket connection, which is blocked by NAT firewall.

Check to make sure your FTP software is using PASSIVE port mode, which causes the FTP server tell your client what port to connect on for a transfer pipeline.

Your symptoms you describe point to the ACTIVE/PASSIVE port issue. Give that a check.

I'm obliged to state that using a smarter FTP program than the default included with Windows is recommended, and that using something OTHER than plain-text FTP for transfers is even more recommended, SFTP, SCP, even HTTPS in a pinch. Plus these can include on-the-fly compression to shorten download times if possible.

share|improve this answer
    
I've tried both PASSIVE and ACTIVE modes, without success. Here's the log of FileZilla: Status: Resolving address of aaaaaa.bbb Status: Connecting to 012.034.056.078:21... Status: Connection established, waiting for welcome message... Response: 220 aaaaaa.bbb FTP server (Version 6.4/OpenBSD/Linux-ftpd-0.17) ready. Command: USER qwerty Response: 331 Password required for qwerty. Command: PASS ********** Response: 230- Debian GNU/Linux Response: 230- Linux kato 2.6.18-6-686 #1 SMP Mon Oct 13 16:13:09 UTC 2008 i686 Response: 230- Response: 230- Response: 230 User qwerty logged in. –  interDist Sep 16 '11 at 13:05
    
Cntd: Command: SYST Response: 215 UNIX Type: L8 (Linux) Command: FEAT Response: 500 'FEAT': command not understood. Status: Connected Status: Retrieving directory listing... Command: PWD Response: 257 "/home/qwerty" is current directory. Command: TYPE I Response: 200 Type set to I. Command: PASV Response: 227 Entering Passive Mode (62,195,21,210,130,85) Command: LIST Error: Connection timed out Error: Failed to retrieve directory listing (Site name and IP address masked) –  interDist Sep 16 '11 at 13:09
    
@interDist That almost looks like filezilla ignored the host:port specified in the passive (PASV) command reply. Very odd. (good try on the masking, missed one). Maybe just for curiosity, is it possible to compare the logs from the Vista machine (which connects?) and the Win7 machine (which fails?), using the same software, of course (FileZilla, in this case). You've tried many different ftp clients, all fail (save cyberduck!), possibly a third-part firewall program on system? (McAfee, Norton, etc). If you use another internet connection, does this behavior change at friend's house? –  lornix Sep 17 '11 at 10:18
    
I tried connecting to the system, of course, it's not publicly accessible, so I cannot verify your results. Your best clues will come from comparing the connection logs from a machine that DOES connect and work, with those from a machine which does not. (uh, yours!). A trusted friend on an alternate OS could help too. Best of luck. –  lornix Sep 17 '11 at 10:21
    
Ok, tested on Vista and Win7, same access point (so not a NAT issue). Vista succeeds, 7 fails on LIST command. The only difference I spotted is in the PORT command, on Vista it is PORT 192,168,1,6,232,223 while on 7 it would be PORT 192,168,1,3,233,21. Can this highlight some clue? BTW, Passive failed on both, so the results are for Active mode. –  interDist Sep 19 '11 at 23:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.