Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm downloading a torrent with over 350 seeders and 2200 leechers. However I only download at about 10 kbps with 5 seeds/leechers.

I'm figuring out it's because utorrent didn't check for speed with other users. How can I force that so that utorrent uses the fastest seeds around?

Also, availability is 8.999 which is weird, shouldn't that be around 350 ?

share|improve this question
    
What OS are you using? –  surfasb Sep 14 '11 at 5:25
add comment

2 Answers

Check the trackers, if any one is not connecting (ex. link not available), delete it. It helps to increase the bandwidth.

share|improve this answer
add comment

Have you checked the number of connections you have set in the preferences?

  1. Open uTorrent.
  2. Click Options and select Preferences
  3. Check the Number of Connections

As you can see from the below screenshot I have a maximum number of 500 connections and share it by limiting each torrent to a maximum of 250 connections each.

enter image description here

share|improve this answer
    
Yes good suggestion but I already have this –  user1190 Sep 14 '11 at 23:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.