Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Why does emacs display a "\" when a line wraps? Visually this is no issue, but if I want to copy a line which also wraps, the "\" character is also copied to the clipboard. How do I get rid of this?

share|improve this question

migrated from stackoverflow.com Sep 14 '11 at 8:56

This question came from our site for professional and enthusiast programmers.

3  
What platform and emacs version are you using? – David Nehme Sep 13 '11 at 19:46
    
I am using RHEL5 and tsch. – Chester Sep 13 '11 at 20:06
    
@David I am using emacs 21.3.1 – Chester Sep 13 '11 at 21:32

I'm assuming you're using emacs in a terminal. In that case the \ is the way emacs tells you that the same line continues in a portion of the emacs "Frame" called the "fringes". Try M-x customize-option RET fringe-mode RET, set it to No fringes, then click the State button and select Save for future sessions.

share|improve this answer
    
I dont have "fringe-mode" in my emacs 21.3.1. – Chester Sep 13 '11 at 21:34
    
Then you'll have to figure out how to get rid of the fringes on your version. – Ross Patterson Sep 13 '11 at 21:36

Try adding this to your .emacs file:

(set-display-table-slot standard-display-table 'wrap ?\ )
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.