Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Ubuntu 10.04 LTS - Lucid Lynx

I have installed Ubuntu server (10.10) using Oracle VM VirtualBox

How to access from host machine to that guest machine.

IP of host machine: *.55.21.16

IP of guest machine: 10.0.2.15

ssh-server on the guest machine is correctly working with:

$ sudo netstat -lntp | grep 22
tcp6        0      0 :::22            :::*               LISTEN     3574/sshd 

How do I connect to that host machine.

Before placing this question I tried http://mydebian.blogdns.org/?p=148 but its not working for me.

Host machine configuration (ifconfig)

eth0      Link encap:Ethernet  HWaddr 00:21:9b:45:7d:06  
          inet addr:1**.1*.99.15  Bcast:1*2.1*.255.255  Mask:255.255.0.0
          inet6 addr: fe**::221:9bf*:fe55:7d06/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:323824 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67861 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:124446873 (124.4 MB)  TX bytes:8365574 (8.3 MB)
          Memory:fe9e0000-fea00000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7412 (7.4 KB)  TX bytes:7412 (7.4 KB)
share|improve this question
    
Can you paste in the details of your interfaces on the host machine? The result of "sudo ifconfig" would do. –  ed. Sep 14 '11 at 14:11
    
do you have any communication between the host and the guest with ping? –  n00b Sep 14 '11 at 18:31
add comment

migrated from stackoverflow.com Sep 14 '11 at 13:47

This question came from our site for professional and enthusiast programmers.

1 Answer

Check the network modes in the virtualbox manual, it seems that the guest and the host don't have any communication.

Sometimes the default configuration (NAT) doesn't fit with the needs, try "Host-only networking".

Have you tried the rdp connection with the guest?

share|improve this answer
    
No I only tried NAT –  suvankar Sep 15 '11 at 16:00
    
the vrdp connection it's another way to access to the vm, but i repeat... you must check that you have a connection between your guest and host, try with ping, it should work. –  n00b Sep 15 '11 at 17:45
    
If i do 'ifconfig' on guest machine it shows its static ip: 10.0.2.15 If i ping from host using 'ping 10.0.2.15' it not working. –  suvankar Sep 16 '11 at 6:41
    
@suvankar try the host-only network it seems that with your config (modem not router) it will be the useful. –  n00b Sep 16 '11 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.