Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is a directory on my (solid-state) drive on OS X (Lion) that makes the computer stall when I try to delete or otherwise access it (no processor or drive activity). What can be attempted so as to delete the directory?

Here is what I tried:

  • Simply putting the directory in the trash and emptying the trash makes the Finder stall.
  • Using rm -Rf en.lproj in a Terminal also stalls (en.lproj is the directory in question; it comes from Microsoft Office 2008); the command cannot be interrupted with Ctrl-C, Ctrl-D or Ctrl-Z.
  • Repairing the disk permissions and verifying the disk with Disk Utility does not help with the above two approaches.

Any other idea would be much appreciated!

PS: I guess that the directory contains files, but I can't see them either the Finder or with Unix commands (ls en.lproj stalls too).

share|improve this question

1 Answer 1

OK, there was a more robust way to try to remove this file, and it worked: I booted the computer in single-user mode (Apple-S), checked the disk with /sbin/fsck -fy and mounted it as a writable disk with /sbin/mount -uw / (as indicated in the messages printed in single-user mode). Removing the directory with rm -R (as usual) worked.

I would guess that for some reason, the files in the directory that could not be otherwise removed were (unduly) used by some program, which made the computer stall…

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.