Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can create new folders on my Windows XP machine, set them to "shared".

On my Mac, I pick Finder → Go → Connect to Server → smb://192.168.1.4 → Connect → Name / Password.

It even shows me all the names of the newly created shared-folders on my PC, but when I try to actually connect to any of them I get

connection failed, there was an error connecting

Any idea on what would cause that? The fact that it successfully gets so far—to actually showing me my PC share-names—must mean I have 99% of this working correctly, i.e. the physical connection, the IP address, the user name, the password, etc.

Still, I can't seem to access the folders themselves.

I've tried this with my Windows XP firewall on/off, and Norton AntiVirus on/off. Same problem.

Everything did work fine, 4 months ago. Were there any odd OS X or Windows updates released recently? I always apply them all.


smbclient on the Mac does correctly find the XP machine, my XP user name, and accepts my XP password.

I get the following from that smbclient command:

Doing spnego session setup (blob length=16)
server didn't supply a full spnego negprot
Got challenge flags: ...
Got NTLMSSP flags: ...
Got NTLMSP flags: ...
Domain=[XPMACHINE] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
tree connect failed: NT_STATUS_INSUFF_SERVER_RESOURCES

I'm not sure why a standard XP box can't "supply a full spnego negprot". Whatever that means.

Using XP's RegEdit to change my IRPStackSize from 11... to 13, 15, 20, 22... still gives that "NT_STATUS_INSUFF_SERVER_RESOURCES" error on the Mac.

share|improve this question
    
On your Mac, open Terminal.app, and enter smbclient //192.168.1.4/name-of-share -d 3 to get us some debug messages from the process. If you have a username, add -U username to this command. We should then be able to see what fails. –  slhck Sep 14 '11 at 21:53
    
@Carol Please register on the site, otherwise you can't have your accounts associated. –  slhck Nov 14 '11 at 19:57
add comment

1 Answer 1

I would suggest using sharing using the Advanced Sharing Options. It has great more customizable options in terms of user control etc. Sometimes shared folders arent accessible to other users (which you can view in the advanced mode).

To activate file sharing in XP, open any window (My Computer, C Drive etc.) and click

Tools -> Folder Options.

On the 'View' Tab, uncheck the option 'Use simple file sharing (recommended)' - It appears in the list below.

Now while sharing, you can select the users for whom you share. Select 'Everyone'. It will work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.