Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My story: I have a laptop with a touchscreen, which is a bit faulty. It jumps the cursor occasionally to one point of the screen. It's annoying, but I managed to find the correct input.

/dev/input/mouse1 < this is the one I should permanently disable in Linux.

How can I do it on Ubuntu 11.04? (Saying the version because the correct answer may vary due to hal/evdev/whatevertheychangestuffdownto software.)

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Adding something like this to /etc/X11/xorg.conf should work:

Section "InputClass"
   Identifier         "disable broken device"
   MatchIsTouchscreen "on"
   MatchProduct       "full product name from 'xinput list'"
   Option             "Ignore" "on"
EndSection

For more matches see http://fedoraproject.org/wiki/Input_device_configuration#InputClasses .

share|improve this answer
    
Nice, gonna try it ASAP! –  Shiki Sep 14 '11 at 22:45
3  
It's generally not recommended to match on specific device paths, as the ordering may change on reboot. MatchIsTouchscreen "on" possibly along with MatchProduct "full product name from 'xinput list'" would be somewhat better. –  grawity Sep 14 '11 at 22:45
    
Strange. @Grawity - Your version works, the "MatchDevicePath" fails for some reason. Thanks, both of you! –  Shiki Sep 14 '11 at 23:17
    
Thanks @grawity, I changed according to to your suggestion. –  Ambroz Bizjak Sep 15 '11 at 8:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.