Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I prevent Opera from switching over to the tab I opened when I click on 'Open in new tab'? This feature of Opera is driving me nuts! Is there a setting or something that I can change so that the focus remains on the current tab?

share|improve this question
    
What a shame. Practically every browser nowdays allows you to configure this option. –  Sasha Chedygov Feb 20 '10 at 18:33
add comment

5 Answers 5

up vote 4 down vote accepted

Ctrl + Shift + Click on the link should open it in a background tab.

but the preference to not change focus to the new tab should be under
Preferences > Advanced > Tabs

EDIT: but Gnoupi says it isn't. :(

share|improve this answer
4  
Actually, you would think that, but no, it's not. Check again your link, you can choose if the next tab will be maximized, or not, things like this, but you can't decide if switching or not. –  Gnoupi Sep 1 '09 at 12:14
2  
the ctrl+shift option is working all right. –  StampedeXV Sep 1 '09 at 12:18
6  
Or, instead of choosing "Open in new tab" you choose "Open in new background tab". No additional work. Just click one line further down. –  StampedeXV Sep 1 '09 at 12:20
2  
jweede - Ctrl + Shift +Click does what I want it to do - pity I can't change it as the default setting. Thanks! –  Sathya Sep 1 '09 at 12:28
1  
@Gnoupi - Keyboard Junkie here :D would rather choose to hit Ctrl + Shift +Click rather than right click, move mouse and then choose Open in New Background –  Sathya Sep 1 '09 at 14:05
show 3 more comments

Just Middle-click on the link will open the link URL in a new background tab. If this is not working for you, Then go to Preferences. Go to Advanced tab. Select Shoutcuts. Click on "Middle Click Options" button. Here select "open in background tab" radio option. Hope this works for you. :)

share|improve this answer
add comment

If you really are a "keyboard junkie", like you said in a comment, then you can do all this from keyboard !

  • Solution 1 (text only) : Press /, type a part of the link, then press Ctrl+Shift+Enter.

  • Solution 2 (all links) : Navigate to your link using Shift+ a directional arrow (you can navigate the whole page in a directional way), then Ctrl+Shift+Enter.

share|improve this answer
    
You mean navigate links using Shift + arrow keys! Ctrl+ keys goes forward/backward –  Sathya Sep 1 '09 at 17:07
add comment

Don't click "Open in new tab". In Opera feature you want is called "Open in Background Tab".

But IMHO best solution is to use middle mouse button click. In Preferences → Advanced → Shortcuts → Middle-Click options you can change how middle mouse button behaves (if it doesn't open in background already).

share|improve this answer
    
Middle click does a Flip-3D (not that I use Flip-3d anyways), but the open in background tab does what I need –  Sathya Sep 1 '09 at 17:12
1  
Never heard of Flip3d. Is that some crapware bundled with mouse drivers? Just disable/remove it and get real middle mouse button working. –  porneL Sep 1 '09 at 19:46
    
Flip-3d -> is the window switcher which comes with Win Vista / 7. –  Sathya Sep 2 '09 at 5:41
2  
@Sathya: Change your settings on the Microsoft Mouse driver (assuming that's what you're using). It has this bad habit of rendering the middle-click useless by default. –  Sasha Chedygov Feb 19 '10 at 0:33
    
@musicfreak - thanks, I have a Logitech wireless mouse, changed the settings in Set point and now its correctly configured! –  Sathya Feb 20 '10 at 13:04
add comment

I can't find an option to prevent that.

The only thing that I can advise you for now, is to "middle-click" the links you want to open in a new tab, or use Shift+Click on a link (this one switches to the new tab, not matching, so).

I'm guessing that this is "by design". If you take the time to make a right click, then clicking on "Open in a New Tab", they assume that you want to switch to it. "Assuming" is always a dangerous thing, and often leads to such problems. Pity they haven't made it an option in preferences.

Edit: I check about:config, but I can't find such option either.

share|improve this answer
    
Middle click does a Flip-3D (not that I use Flip-3d anyways), but yeah with shift-click it switches over to the new tab. But yes - pity they don't have the option. –  Sathya Sep 1 '09 at 12:27
1  
You might be able to turn off the middle-click activating Flip-3D using the Mouse control panel. I've got mine set to 'middle click' and it works fine. –  Ant Sep 3 '09 at 15:08
add comment

protected by Diago Nov 18 '10 at 19:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.