Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently something in Windows 7 has changed such that the default action for removable drives has become Install or run program from your media instead of Open.

I checked the AutoPlay control panel applet and everything is set to Take no action (in fact, the master check-box Use AutoPlay for all media and devices is cleared as well).

I also searched through the CLSID key in the register and could not find it in any of the Shell keys, so I figure it must be in one of the ShellEx keys.

Finally, I searched for information on this, but found nothing on how to disable (or better yet, remove) that option and revert the default action to Open.

share|improve this question

5 Answers 5

I found the solution by deleting the following registry key (where X is the letter assigned to the volume in question):

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2\X
share|improve this answer
    
Hmm, I’m not sure that should be the cause (maybe a side-effect of some other underlying issue), but next time I see it happen, I’ll give it a shot. –  Synetech Mar 30 '13 at 14:16
    
Yeah, I got this: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints‌​2\F\shell\AutoRun\command @="F:\AutoRun.exe" and HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints‌​2\F_Autorun\DefaultIcon @="F:\Signal.ico" So my guess is it's some weird wifi/3G driver or something. –  Mark 14 hours ago
    
The registry key creation date matches the date I installed drivers for a Huawei "3 USB Modem", so if you've done the same just delete the whole key for that drive. –  Mark 14 hours ago

Similar to DiableNoir's advice, if that didn't work out for you, please try the following:

  • Open the Run dialog (Windows key + R), and type gpedit.msc

The Local Group Policy Editor appears.

  • In the left Pane, Expand Computer Configuration
  • Expand Administrative Templates, under Computer Configuration
  • Expand Windows Components under Administrative Templates
  • Click AutoPlay Policies

In the AutoPlay Policies pane:

  • Double-click the Set the default behavior for AutoRun list option
  • In the corresponding dialog that appears, on the left, click the Enable button
  • Down the bottom of that window, under Options, select Do not execute any autorun commands from the dropdown menu.
  • Click OK.

Restart your computer.

share|improve this answer
    
There is no group-policy editor in Home. And like I said, AutoPlay is already set to do nothing. –  Synetech Jul 27 '12 at 13:20
    
In "Home". You're looking in the wrong place, then. –  Arrow Aug 1 '12 at 18:02

I've seen such problems yet. I've tried your listed methods, and without result.

The shortest way was to run Kaspersky Internet Security and start "Vulnerability Scan".
It found that 'autoplays' of CD/DVD, USB drive, HDD and network disks are enabled and disabled them.

share|improve this answer
1  
Then yours was a basic handler and you could have simply used Autoruns. The problem is when the item isn’t a basic handler. There are at least half a dozen places where context-menu items can be registered, so finding out where the heck this item is coming from can be a headache. –  Synetech Feb 8 '13 at 23:39
1  
I know what are you talking about. I'd almost the same problem on another PC. And also I tried all Sysinternals' tools. But this helped me then. Maybe it'll help you too... –  Jet Feb 9 '13 at 23:55
    
Thanks, but I’m not about to install Kaspersky just to do what can/should be done by just deleting a registry key. Are you sure yours was actually the Install or run program from your media menu item and not something else? –  Synetech Feb 10 '13 at 4:04
1  
Yes... Also check your drives for viruses, because there're some viruses like that. Delete Autorun.inf-s in that drive and create a FOLDER named Autorun.inf in that drive. This will prevent a virus from creating autorun.inf. It can help you too. –  Jet Feb 10 '13 at 9:58
    
But autoruns.inf and viruses have nothing to do with the menu entry, it’s part of Windows; something is triggering its use. The folder tip is good though; in fact, ~8 years ago I did exactly that to stop a program from constantly creating and accessing a file in c:\windows. It was really stupid and annoying, so I made a folder with the same name and set it to read-only, system, and hidden. The program could no longer create or access the file. (Of course it’s not difficult for a program to clear the attributes and delete the existing object, but most tend not to, so it’s worth doing.) –  Synetech Feb 11 '13 at 0:53

Just delete this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers

This will reset all Autoplay settings for all media. You should now be able to change the settings. The dialog control panel / Default Programs should create a new key. (So it's safe to delete that key.)

Please note that administrators can create policies which deactivate Autolplay. If you are using the Professional/Ultimate/Enterprsie-Edtion of Windows and your are a administrator, you should also check the Local Policies:

Autploay Group Policy

share|improve this answer
    
I can’t test this right now because I’m not experiencing the problem anymore for some reason (that registry branch is present). Either way, I don’t think it’s an Autoplay issue, or at least should not need to use a scorched-Earth fix like that. I just need to figure out where that string is coming from. –  Synetech Oct 15 '11 at 21:15
    
I'm sure that your problem is a result of a broken AutoPlay-Key. Please delete that key and let Windows create a new one, before trying other solutions. You will never find the string because it's part of the Shell32.dll and not of the registry. –  DiableNoir Oct 16 '11 at 16:13
    
Except that I don’t have the problem right now. It comes and goes for some unknown reason. Again, I don’t believe it has anything to do with Autoplay; it is an incorrect handler. It doesn’t matter if the string is a resource in shell32.dll, there should still be some kind of connection in the registry (eg, a shellex key that points to shell32.dll). –  Synetech Oct 16 '11 at 17:58
    
I think the key already contains the connection to the shell32.dll and Windows Explorer. It defines for all storage types the values MSOpenFolder, MSAutorun,... But, every program is can edit this values because the key is saved under HKEY_CURRENT_USER. I think there is a application on your computer which chances this settings. –  DiableNoir Oct 17 '11 at 13:15
    
Okay, I just got it again today with a new device (which makes me suspect that it is a default setting with new devices and does not happen once you set the action for devices that Windows has seen before). Any, I tried your suggestions, but they did not work. :-( –  Synetech Dec 10 '11 at 23:36

I also faced this problem and could not find any solution for this problem online.

Here is the way I got it corrected. Since I believe this problem is associated with drive letter of USB, changing the drive letter should help. Follow these steps :

  1. Connect USB and go to disk management (right click computer - > manage -> Disk management under storage group)
  2. Right click on USB drive letter and select "Change Drive Letter and Paths.."
  3. Click on change - > select other drive name except which you already had
  4. Click Ok
  5. Yes for the warning

Boom !! Try your USB, error resolved ...!

PS : If you want to use your USB for any electronic media(TV, Car music etc.), make sure that format of pendrive is NTFS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.