Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why is my "Enable Hybrid Boot" option grayed out in Windows 8, and how can I enable it?

enter image description here

Performing a powercfg /a results in the following error being reported:

Hybrid Sleep: The hypervisor does not support this standby state.
share|improve this question
    
Ask here. you shall get an answer- social.msdn.microsoft.com/Forums/en-US/… –  Gulshan Sep 23 '11 at 12:46
    
see if it has a check mark beside it. If you want to adjust this setting, click on "Change settings that are currently unavailable" –  user98957 Sep 23 '11 at 16:38
    
Without any details on your computer/OS/drivers, we can only guess; can you provide some specifications? –  Tom Wijsman Nov 24 '11 at 13:36
    
@TomWijsman: Sure, see here. –  Mehrdad Nov 24 '11 at 17:49
1  
@TomWijsman: It says Hybrid Sleep: The hypervisor does not support this standby state. Which is funny, because I don't even believe I'm running on a hypervisor... –  Mehrdad Nov 27 '11 at 23:11
show 4 more comments

4 Answers 4

“Enable Hybrid Boot” is grayed-out when it is unavailable for some reason.

From What is Hybrid Boot in Windows 8 and how does it work? :

To use Hybrid boot, your system must have a hibernation file and the drivers must support hibernation. Hybrid boot is not available if you run Windows 8 in a Virtual Machine.

To change Hybrid Boot in spite of it being unavailable, you will need click on "Change settings that are currently unavailable", but this will probably have no effect (or worse) :

enter image description here

share|improve this answer
    
I'm on a physical machine with a dedicated partition, and hibernation is enabled... –  Mehrdad Nov 20 '11 at 21:49
    
If the hibernation file is large enough, then what is left in the equation are the drivers, which might not be evolved enough for Windows 8. I suppose we might be talking here about disk drivers, maybe chipset driver, and maybe even the BIOS. Try to find updates on the manufacturer websites, or you may need to wait for Windows 8 to be released for good drivers to become available. –  harrymc Nov 21 '11 at 8:20
    
I don't understand why it would need special drivers though... it seems kinda random, considering that hibernation and hybrid boot are fine... –  Mehrdad Nov 21 '11 at 8:40
    
Every new Windows version requires driver-writers to adapt to it, which Microsoft can force by virtue of its near-monopoly. It doesn't shock me that manufacturers may not have yet come up with fully-compatible software. –  harrymc Nov 21 '11 at 13:45
    
It seems like that's nothing more than a guess. I could've guessed the same thing, but I was hoping for something more... thanks anyhow... –  Mehrdad Nov 24 '11 at 3:46
show 8 more comments

Hybrid Boot is disabled when ...

  • ... you have Hibernation disabled, you can enable it by executing powercfg /h on.

  • ... your computer doesn't support Hibernation, this is rare but possible.

  • ... your drivers don't fully support Hibernation, often seen when you use Virtualize or VHD boot.

    It is best to run your OS natively and make sure all your drivers are installed, WHQL and up-to-date.


More explanation on why it doesn't work can be received by using powercfg /a.

In case you get the error The hypervisor does not support this standby state, you need to uninstall Hyper-V to fix this error and reboot your system which should make the grayed out option available to you...

share|improve this answer
    
Someone else already mentioned all of these, but it's none of them: superuser.com/questions/335792/… ... hibernation works completely fine. –  Mehrdad Nov 24 '11 at 17:48
    
@Mehrdad: I don't see VHD booting nor driver support mentioned. Updating your drivers is your best bet... –  Tom Wijsman Nov 24 '11 at 17:51
    
Oh, that's what I meant by "a dedicated partition" -- i.e. I'm on a physical partition, not a VHD file. And no, my drivers are fine, that's not the issue... –  Mehrdad Nov 24 '11 at 18:04
    
You didn't answer my question but at least you mentioned powercfg /a so I'll give ya the bounty =) –  Mehrdad Nov 27 '11 at 23:39
    
@Mehrdad: I really don't have a clue, perhaps you could try to ask at the Windows 8 DP forums how you could troubleshoot that error or wait for Windows 8 to release itself. There is no information on that error yet as far as I can see so unless someone else has the exact same problem (and doesn't have an obvious reason to have that problem) I guess all you could do is fiddle with devices/drivers... –  Tom Wijsman Nov 27 '11 at 23:42
show 7 more comments
up vote 0 down vote accepted

Ahh I finally figured it out. :)

There were two steps to solving this problem:

  1. I needed to uninstall Hyper-V from the Windows features (in Programs and Features in the Control Panel).

    This is pretty surprising, considering that I was not supposed to be running on a hypervisor, and that the script from here indeed said my baseboard manufacturer was Sony, not Microsoft.

  2. I manually re-enabled hybrid boot through changing the following registry setting:

    Under

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power
    

    I changed the DWORD named HiberbootEnabled to 1.

Indeed, after the change, boot was much faster, but now it didn't give me the option to boot into another OS like before. (Instead, Windows 8 took over, and asked me what I wanted to do.) The "shutdown" was slightly slower, though.

share|improve this answer
add comment

It is already enabled. The boot is much faster because the system files are stored from ram to disk like in the usual hibernation, but the services are restarted on reboot. That gives the system a real fresh start with the speed of hibernation.

share|improve this answer
1  
er, how do you know it's already enabled? –  Mehrdad Sep 16 '11 at 19:43
1  
Wrong: The Hybrid Boot check-box is unchecked, so it is not enabled. –  harrymc Nov 21 '11 at 13:47
    
Indeed wrong, my VHD boot outperforms my Windows 7 installation but does not support Hybrid Boot. Yet, my shiny SSD laptop gets outperformed by a native install on a 6 year old laptop with a 5400 RPM drive that does support hybrid booting. Also, it's not the services that are restarted but rather the devices... –  Tom Wijsman Nov 24 '11 at 17:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.