Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried using webRDP, which is a Java-based (so multi-platform) RDP client that can work as a standalone program (single .jar file) or embedded on a web page.

When I try connecting using it by double clicking the .jar file, I get The server has reset the connection, on both Windows Server 2008 R2 and Windows 7. I tried all sorts of credential combinations with domain names (long and short ways) and without.

When I tried using it from a webpage, I got the following error in the Java Console:

Java Plug-in 1.6.0_26
Using JRE version 1.6.0_26-b03 Java HotSpot(TM) Client VM

load: class com.webinflection.webrdp.MainApplet not found.
java.lang.ClassNotFoundException: com.webinflection.webrdp.MainApplet
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Exception: java.lang.ClassNotFoundException: com.webinflection.webrdp.MainApplet

What is causing these problems?

This is the unmodified html page that I am using. I thought I'd try getting it working before I go through the proper configuration:

<html>
<head>
<title>webRDP&#0153;</title>
<meta http-equiv='content-type' content='text/html; charset=iso-8859-1'>
<meta http-equiv='content-style-type' content='text/css'>
<meta http-equiv='expires' content='Wed, 26 Feb 1997 08:21:57 GMT'>
<meta http-equiv='pragma' content='no-cache'>
<!-- Sets margin around applet -->
<style>
body.swproxyBody { margin:4px;; }
</style>
<script type='text/javascript'>
// This method is called after the user logs out of their RDP session. The method name is
a configurable applet parameter.
function rdpOnLogout() {
alert ( ' User has Logged out ' );
}
</script>
</head>
<body class='swproxyBody'>
<!-- Loads the applet and utilizes 100% of browser window width and height. Width and
height could be hard coded to specific values -->
<applet name='rdp' code='com.webinflection.webrdp.MainApplet' archive='webRDP.jar'
width='100%' height='100%'>
<!-- Hostname or IP Address of Terminal Server -->
<!-- This is a required parameter -->
<param name='host' value='10.1.1.25'>
<!-- Port that the Terminal Server -->
<!-- This is a required parameter. -->
<param name='port' value='3389'>
<!-- Username to authenticate to Terminal Server with -->
<!-- Optional SSO Parameter -->
<param name='username' value='joe'>
<!-- Password to authenticate to Terminal Server with -->
<!-- Optional SSO Parameter. If left blank, the Terminal Server will prompt the
user to supply their password.-->
<param name='password' value='cat1dog2'>
<!-- AD Domain name to authenticate to Terminal Server with -->
<!-- Optional SSO Parameter. In some Terminal Server deployments, this
parameter will be required. -->
<param name='domain' value=''>
<!-- Application to start. This value should be url encoded. In this example we are
launching c:\windows\system32\notepad.exe-->
<param name='program' value='c%3A%5Cwindows%5Csystem32%5Cnotepad.
exe'>
<!-- Working directory for Application. This value should be url encoded. In this
example the working directory will be set to c:\windows\system32\ -->
<param name='directory' value='c%3A%5Cwindows%5Csystem32%5C'>
<!-- In this example I used a site ( http://meyerweb.com/eric/tools/dencoder/ ) to
encode the above values -->
<!-- This specifies a javascript method to be called after the user logs out of the
RDP session. This stops the session from hanging is a disconnected state. -->
<param name='onlogout' value='rdpOnLogout'>
</applet>
</body>
</html>
share|improve this question

1 Answer 1

Problem 1, with the server(s) resetting the connection, odds are you need to set Windows to allow all Remote Desktop Clients. webRDP doesn't currently support NLA or TLS.

Problem 2, with running it from a web page, it would appear the Jar is incomplete or corrupt, or that the browser isn't able to find the Jar, based on how you're referencing it in the code. Without seeing the HTML you're using to embed it, and the files and file permissions, that's the best I can give ya.

share|improve this answer
    
Thanks, but I still have problem 2. The md5 checksums are the same, so I am sure that the file is no corrupt. I am using the html webpage from the Configuration Guide, with no modifications (until I get it working). Do you think it could be a file ownership issue? –  paradroid Sep 17 '11 at 13:16
    
Possibly, are you doing this all locally from a folder on your machine, or are you actually publishing it to a web server and trying to use it from there? the likelihood of it being a permissions / ownership problem is greater in the latter example. –  peelman Sep 18 '11 at 4:24
    
It's being hosted on a Linux server (Debian) running Apache. All the files are owned by the Apache user (www-data). Doesn't it seem like this is the problem in the example html webpage?: <applet name='rdp' code='com.webinflection.webrdp.MainApplet' archive='webRDP.jar' width='100%' height='100%'> –  paradroid Sep 18 '11 at 5:01
    
what happens if you try to hit the applet directly from the web browser? and/or change the relative path of the applet to be a fully formed URL? –  peelman Sep 18 '11 at 5:32
    
When I use the full path of the applet the browser tries to download it. Using the full URL in the archive= field gave the same error. I am using HTTPS, if that makes any difference. I've added the html webpage to my question. Thanks. –  paradroid Sep 18 '11 at 10:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.