Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have got SSH on my remote ubuntu box and Remote desktop enabled. I am trying to use X-windows on my Windows machine.

I have installed Cygwin/X - however the user guide tells me how to run XServer in Windows. I would like to connect to my Ubuntu machine (I have verified that this box X11 + Port forwarding done correctly as I can ssh -x into that box from a remote linux box).

I have done this but I get the following error:

2 [main] Xwin 9192 fork: child -1 - died waiting for longjmp before initialization, retry 0, exit code 0x600, errno 11

Can someone explain how to use Windows Cygwin/X and open up windows of a remote Ubuntu box?

share|improve this question
Is your windows 64bit or 32bit? –  Nifle Sep 15 '11 at 11:27
32 bit windows :) –  Calm Storm Sep 16 '11 at 8:41

2 Answers 2

I probably has nothing to do with Xwin, but is probably a problem with fork()

Try this:

Due to issues with Cygwin's fork() and DLL base address
conflicts, one should rebase their Cygwin system to prevent fork()
failures.  Use the following procedure to rebase your system:

a. install the Cygwin rebase package (if necessary)  
b. shutdown all Cygwin processes  
c. start bash (do not use rxvt)  
d. execute rebaseall (in the bash window)
share|improve this answer

The easiest way to simply connect to a linux box, from windows, is with something simply like PuTTY (which is free to download).

If you can't connect with PuTTY then you may have a networking of firewall problem (although from your description Nifle's suggestion of a DLL problem sounds right).

PuTTY will also provide you with X11 forwarding, so you won't have to use ssh -x directly.

If PuTTY works and ssh -x from within a Cygwin shell, doesn't, then try Nifle's forking/rebase solution.

If you want to get X Forwarding to work with Cygwin/X and PuTTY as a terminal window, follow my instructions here: How do I get X11 Forwarding to work on Windows with PuTTY and Xming? At the very least, you may need to configure the -listen tcp bit of Cygwin/X, so it will accept incoming X connections (if you're X forwarding from bash running on Cygwin, then the XAUTHORITY parameter will probably already be set, so the 2nd part of the instructions will be moot)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.