Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this USB microphone, and I usually keep it connected to my Windows XP box for recording, but since there are not too many USB ports on it, I sometimes have to disconnect it to use the port for another device. The problem is, everytime it is reconnected it sets itself as the default sound output device.

It is quite annoying that I have to configure the computer's sound devices everytime I plug in the mic, so I was wondering if there is any way to disable Autoplay in Windows XP for a certain device (not all of them, because I use Autoplay on some of my other USB devices).

share|improve this question
1  
    
@techie007 I don't care about the notifications, it's the background process that I want to stop –  Nate Koppenhaver Sep 15 '11 at 22:10
1  
I think what you're running into isn't related to AutoPlay; Perhaps try disabling AutoPlay completely, see if that stops the effect you are seeing. If not, you know it's not probably not AutoPlay, and that you may need to approach it from another direction. It's definitely odd a microphone would become the default output device. –  Ƭᴇcʜιᴇ007 Sep 15 '11 at 23:54
    
@techie007 I completely disabled autoplay, and it doesn't do that anymore –  Nate Koppenhaver Sep 16 '11 at 17:33
    
And it starts doing it again once you (re)enable AutoPlay? –  Ƭᴇcʜιᴇ007 Sep 16 '11 at 22:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.