Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This command works fine

find ~/mypath -name *.fstq -print|xargs curl -u sdd:dsdsd -T

but when I add

find ~/mypath -name *.fstq -print|xargs curl -C- -u sdd:dsdsd -T

I get an error message

curl: (25) Failed FTP upload: 451
curl: (3) <url> malformed
curl: (3) <url> malformed
curl: (3) <url> malformed

any ideas how I can use resume (-C-) option with this pipe?

share|improve this question
Can you add an "echo" between the | and xargs, to see what command it's actually running? – ed. Sep 16 '11 at 14:36

Isn't there a space after the -C, like "-C -"?

share|improve this answer
You are right, I tried using the space after but it produced the same error regardless of the fact. – biomed Sep 16 '11 at 2:19
You are probably uploading fastq files for publishing. I seem to remember that there are certain restrictions to the FTP servers (maybe they do not allow reading uploaded files and thus the SIZE command will fail). So before you blame the command try uploading to a FTP server you have full control over. – Ole Tange Sep 20 '11 at 17:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.