Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new in making web servers. I installed Apache web server in my computer and I forwarded a port 80 on my Router. When I type http://localhost, or my local IP ie in my web browser it loads the default page of Apache server from the hard disk on my local pc.

I want to display that page when user type my WAN IP in his/her web browser. The problem is that the WAN IP navigates the browser to my router's configuration page. How do I display My web page instead of the configuration page of my router. I am using ZTE ZXDSL831CII router.

share|improve this question

migrated from Sep 16 '11 at 7:40

This question came from our site for system and network administrators.

Are you accessing your WAN IP from the same computer or another machine outside your network? – Hydaral Sep 16 '11 at 9:02
up vote 3 down vote accepted

Most routers I have used (in a home setting) does not allow connecting to the outer world-facing IP from the inside.

Try accessing your own server through an online proxy like to see if that works.

If you still get your configuration page you have allowed access to your router from outside, try turning that off and try again

The configuration page should for security reasons only be visible from inside behind the router and that is the default setting for most routers.

share|improve this answer

You need to forward port 80 from your router to the server (computer with Apache installed), and change the remote management port from 80 to something else (I use 8080; make sure your password is set), or turn off remote management entirely. Ensure your internet service provider (ISP) supports this server-type connection under your contract -- mine does not without a "server" package, blocking several key ports and choking upload rates.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .