Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got an Intel GMA X4500 HD video card in my laptop and some hardware-accelerated games (for example Valve's Portal and Braid of the second Humble Indie Bundle) rotate the screen 90-degrees. I am pretty sure the card and the machine performance is more than enough to play them comfortably, but this nasty bug prevents me from playing them. Any ideas on how to fix this? The OS is Windows XP SP3, the video card driver and Direct X are of the latest versions available.

share|improve this question
    
I've never heard of this happening. Out of curiosity, are they all running through Steam? –  Shinrai Sep 16 '11 at 14:18
    
@shinrai, Portal is from Steam, Braid is not (can be got from steam also though, afaik). –  Ivan Sep 16 '11 at 16:51
    
It can, that's why I asked. (I know I registered all my HIB games through Steam.) –  Shinrai Sep 16 '11 at 18:00

1 Answer 1

It's not the game. You are probably bumping ctrl + up arrow while you are playing the game.

Intel includes a Hot Key function with the driver software that allows rotation. If you look in the system tray, you may see the intel graphics accelerator tray item. If you go through the menu that pops up when right-clicking on it, You can disable the Hot Keys feature.

If you don't see the icon in the system tray, go to MSConfig > Startup tab> uncheck hotkeycmd

share|improve this answer
    
Alternatively Hotkeys can be disabled from control panel>classic view>Intel Extreme Graphics>Hotkeys Tab –  Alpine Sep 16 '11 at 15:35
    
I am not bumping anything. As I start the game the screen goes rotated as soon as it gets captured by the game. If I Press Ctrl+Alt+Up to bforce normal rotation during the game, the game crashes. –  Ivan Sep 16 '11 at 16:52
    
Do you have the game running at your screens native resolution? Or does it change the resolution when you play the game? –  Dustin G. Sep 16 '11 at 20:40
    
My screen native resolution is 1440x900. When I run such a game the first time (before I have a chance to configure it), it switches to 900x1440. With some games (like Portal) it helps to go to the configuration menu and choose the right resolution, but some games like Braid don't let it be done so easily. –  Ivan Dec 26 '12 at 20:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.