Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need Firefox 3.6 for a website that only allows Firefox 3.x or IE 8.0 or below. I have uninstalled the current version of Firefox on Ubuntu and have downloaded the correct installer, but there are no instructions for installing it.

share|improve this question
add comment

2 Answers

If its a tar.gz you need to expand it with tar -xf and run it from in there (or copy it to /usr/local).

There may be a README file there with details. If its a .deb, you can install it with

sudo dpkg -i (packagename).deb 

or double clicking on it

share|improve this answer
    
The tar.gz file for 3.6.25 on mozilla.org/en-US/firefox/all-older.html contains a README which only refers to the web site (a non-existing page there), and the firefox binary there doesn't start (error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory) on a current Ubuntu. –  Paŭlo Ebermann Jan 25 '12 at 10:51
    
Its an old question with insufficient information - your issue may be different. From your error, it looks like you're lacking a prerequisite - try installing libgtk-x11 from your package manager and see if it works –  Journeyman Geek Jan 25 '12 at 11:58
    
Current Ubuntu doesn't provide this package (at least, not under this name). I solved the original problem by managing to instruct my package manager to install the package from an older Ubuntu (Maverick), and it then actually showed I didn't even need an old Firefox (as we found a GWT development plugin for Firefox 9). Still, thanks for your response. –  Paŭlo Ebermann Jan 25 '12 at 18:46
add comment

You can find it the official web site or here

EDIT : 'here' link updated

share|improve this answer
    
Your "here" download offers only Windows versions. –  Paŭlo Ebermann Jan 25 '12 at 10:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.