Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mistakenly assign Office Outlook to open my .eml files in Windows 7. But, as Outlook do not open such files, I downloaded Live Mail, but now I can not assign it to open this kind of file by default.

I've tried running Explorer as Administrator, not to avail.

enter image description here

share|improve this question
    
Wow, that's lame. –  Jeffrey Sep 1 '09 at 14:30
    
Yeah, pretty lame having to download a program just to change the setting. –  Eduardo Molteni Sep 1 '09 at 15:04
    
Wow, I never noticed that the File Types tab of Folder Options is gone. Populating the dialog is slow and I use .reg file to manage file-types, so I never use it, but obviously a lot of people relied on it and have to resort to other methods now. For the record, the box is grey sometimes depending on the extension and context (it’s always greyed for executable types). –  Synetech Aug 30 '12 at 14:44

7 Answers 7

up vote 18 down vote accepted

Windows Vista and Windows 7's file type management facilities are half-baked at best. I never understood why Microsoft crippled that part of the OS when they released Vista. They added limitations that make absolutely no sense.

You might want to try to use alternatives listed in my previous question on the matter:

What program do you use to edit file associations in Vista and Windows 7?

The program that stood out was Default Programs Editor which is free and will allow you do pretty much whatever you wish to do.

Screenshot

share|improve this answer
    
This is amazing: Using "Default program Settings" gives me the error "The default programs association for some extensions could not be saved due to a registry permissions issue. This could be a result of a previous tweaks by other programs to your settings" (doh!) –  Eduardo Molteni Sep 1 '09 at 14:59
    
Using "File type settings" and trying to delete the extension crash the program (I think due to permissions also) –  Eduardo Molteni Sep 1 '09 at 14:59
    
Note that I'm running the program as Administrator –  Eduardo Molteni Sep 1 '09 at 15:00
3  
Yahoo!! Using "File type settings" and editing the "Open" context menu solved the problem!! –  Eduardo Molteni Sep 1 '09 at 15:03
    
I guess the permissions in the registry were messed up majorly. –  Andrew Moore Sep 1 '09 at 15:08

My answer relates to a similar, but not the same, problem, where I can't associate a file extension with a program with the same name of a deleted program previously used for this extension, when the new program is located in a different path. Nonetheless, this should be relevant to your case.

As others have noted, broken registry entries explain this behavior. I used CCleaner to get rid of the erroneous entry after I tried and failed to get rid of it by myself. This seems to happen when a program used to open a specific file type is deleted and you try to associate this file type with another program with the same name installed elsewhere. When this happens, Windows gets confused about the program used to open it, and the system can't associate the file extension with the new program.

You may want to look at this answer for more information and some cautions on registry cleaners including CCleaner.

share|improve this answer

To change an extension to not be opened by any program:

  1. Create a text file with a line of gibberish in it.
  2. Save to your desktop with the .txt extension.
  3. In Control Panel, go to the extension for which you want to remove the default association.
  4. Assign the above text file to be the default program for that extension.
  5. Close Control Panel.
  6. Go back to the text file and delete it.

The extension that was associated with this text file in step 4 will now show it is associated with an "unknown" program.

share|improve this answer

An old question, but had the same problem and this simple tool fixed it for me. Simply select the extension and click on "Delete file type". After that, the option was no longer greyed out. http://www.winhelponline.com/articles/231/1/An-Utility-to-Unassociate-File-Types-in-Windows-7-and-Vista.html

share|improve this answer

you may use the File Type Doctor which is part of the Creative Element Power Tools to fix this.

alt text

share|improve this answer

Since the registry entry may be botched, another way to fix this might be to run a registry cleaner (I used Eusing Free Registry Cleaner) that will detect an invalid entry and delete it. Afterwards, you can try again to associate the extension the normal way. This worked for me, after I had switched from a portable to a system installation, and the registry still pointed to the portable installation.

share|improve this answer
    
I use CCleaner's registry cleaner, and this works as well. However, see superuser.com/questions/282539/… for some cautions. –  DragonLord Sep 22 '12 at 20:13

Is "NoFileAssociate" set to 0?

From KB555076:

  1. Go to "Start" -> "Run".
  2. Write "Regedit" and press on "Enter" button.
  3. Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer
  4. In the right side of the screen double click on "NoFileAssociate".
  5. Change the value of "NoFileAssociate" from 1 to 0.
  6. Close "Regedit".
  7. Reboot the server.
share|improve this answer
    
There is no key, and adding it makes no difference –  Eduardo Molteni Sep 1 '09 at 14:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.