Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top offers free TV recordings, and AviDemux can cut out the commercial breaks without requiring recoding. However, many recordings have black bars either on top and bottom or at the left and right side due to the various aspect ratios used, resulting in a 4:3 coded 16:9 movie showing black borders on all four sides in fullscreen mode on a 16:9 monitor (top and bottom because of the movie, left and right because VLC doesn't know they are superflous and that 4:3 has to be fit on the 16:9 screen). Cropping the black bars with AviDemux would require a recoding, so

is it possible instead to let VLC display only the borderless part of the video?

I.e. somehow provide a config file or initially choose a "zoom" section.

Bonus question: I'll award a bounty of 100 rep for any automatic on-the-fly border detection and removal solution, be it VLC or other means, as long as it's free.

share|improve this question

Simply go to VLC Player preferences > Video (you must be in "All" mode, not "Simple" mode). On the right-hand side, scroll down to "Video cropping" and type in either "16:10", "16:9", or "4:3", depending on what your screen's aspect ratio is. Press the Save button at the bottom.

If black lines remain, then they are actually part of the video as opposed to just an empty section of the screen. In this case, adjusting manually is the only logical option left.

share|improve this answer
Register your account so you can edit your own posts directly and not have to submit them to the review queue. – Scott Aug 10 '13 at 2:24
If you need access to this account to register it, use this tool - then register, so you can stop creating new accounts every time. – Shog9 Aug 10 '13 at 5:16
Interesting setting, thanks! Though this means that e.g. a truly 4:3 video played on a 16:9 screen will always get top and bottom cut off. Unless there is a way for VLC to detect the presence of black borders to cut off I'll stick with manually setting this. – Tobias Kienzler Aug 10 '13 at 6:15
up vote 2 down vote accepted

Well, I should have checked VLC's Video menu as I did while posting this question... There's the crop to 16:9 option I was looking for... Anyway, if you find an automatic cropping estimation method, the bounty will still be there.

share|improve this answer
+1 for posting the solution as an Answer, and also especially for leaving the bounty in tact. – Randolf Richardson Sep 16 '11 at 20:51

If you press C it will toggle through the crop ratios and may help you with eliminating the black bars.

share|improve this answer

Select 'tools', go to preferences, select 'Crop', and control the width and height of the frame until the bars are gone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.