Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Adobe CS4 Master Collection on my MacBook Pro after a clean install of Snow Leopard and Flash CS4 crashes on launch. Usually, apps that crash cause the OS X to create a crash log that can be found in /Library/Logs; however, Flash CS4 is crashing right on start-up. I see the icon bounce on the Dock once, maybe twice, then it disappears with no error or crash report.

How can I determine why an application is failing to launch? Surely, there is some event log somewhere... Shirley?

share|improve this question

Try opening up the console app and watch that. I've seen stuff show up there but not on the logs.

share|improve this answer
I'm unsure if you implied this or not, but try launching the program from the terminal, as well. – Babu Sep 1 '09 at 20:04
Thank you both. I tried executing open "./Adobe Flash" using the terminal from the Adobe Flash CS4 directory and saw no additional information. The app icon bounced twice, disappeared, and the console returned to the default prompt. After listening to Adobe's customer service hold music for 1 hour and 47 minutes with never speaking to a live person I gave up on telephone support. I have now gotten in touch with someone via email that cares, so I have hope that my problems will be resolved. I'll follow-up with the solution here. – Michael Prescott Sep 1 '09 at 21:20
I think Decompyler mean "Console" app and not Terminal. Console logs all events that occur with your applications. – Tiago Veloso Sep 1 '09 at 22:34
Thanks Fork, that actually revealed some information. 9/2/09 8:28:16 AM [0x0-0xd30d3].com.adobe.flash-10.0[3614] /System/Library/Frameworks/‌​amework/Versions/A/Support/LaunchCFMApp[3614] Launch failed with error code -2857 (cfragCFragRsrcErr) for application /Applications/Adobe Flash CS4/Adobe Flash Flash CS4 9/2/09 8:28:16 AM[98] ([0x0-0xd30d3].com.adobe.flash-10.0[3614]) Exited with exit code: 215 It means nothing to me, but one day when Adobe responds to my requests for help, I'll have some information that may help. – Michael Prescott Sep 2 '09 at 13:31

I had a very similar issue with Flash CS4 on Snow Leopard. I fixed it by booting the machine into safe mode (hold shift key during startup). Once in safe mode, I started Flash. Once it launched, I quit Flash, then rebooted normally. After this, Flash appears to work correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.