Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Mac OS X 10.7 (Lion) Apple has replaced good old SMB support. Now I can't auto connect to my shared (SMB) network drives. Workarounds? Or is this impossible? In OS X Snow Leopard, I could automatically connect my Ubuntu (SMB) shared network drives with auto_smb / auto_master (autofs configuration in /private/etc/). I made three mount points (folders) directly in '/Volumes', I used /Volumes/Data and /Volumes/webroot (both SMB shared).

Unfortunately Lion doesn't connect (automount) my network drives. I have to manually connect to the server (Ubuntu file server) in Finder, then open up Terminal to navigate to the mount points, and then it connects. This is not a workable solution. I've searched (Google/SO) but found no solutions apart from an unsupported hack.

Isn't it possible anymore to automatically connect to an SMB-shared drive during startup?

share|improve this question
add comment

migrated from stackoverflow.com Sep 17 '11 at 9:07

This question came from our site for professional and enthusiast programmers.

5 Answers

sudo bash
mkdir /Volumes/Network
vi /etc/fstab

Add something like the following (1 mount per line)

192.168.0.200:/video /Volumes/Network/Video url automounted,url==cifs://user:[email protected]/video 0 0
192.168.0.200:/music /Volumes/Network/Audio url automounted,url==cifs://user:[email protected]/music 0 0
192.168.0.200:/public /Volumes/Network/Public url automounted,url==cifs://user:[email protected]/public 0 0

run automount -vc

bash-3.2# automount -vc
automount: /net updated
automount: /home updated
automount: /Volumes/Network/Audio mounted
automount: /Volumes/Network/Watch mounted
automount: /Volumes/Network/Video mounted
automount: /Volumes/Network/Public mounted

Get out of the sudo session. Browse in finder to /Volumes/Network - whenever you go there they will now just automount. Just tried this in 10.7.3 and it works fine.

If you get an authentication error like the below, it is likely that the login/password combination entered into /etc/fstab is incorrect. Make sure to rerun automount after correcting the password.

$ sudo automount -vc
automount: /net updated
automount: /home updated
automount: /Volumes/Network/Computing updated
automount: no unmounts
$ sudo ls -l /Volumes/Network/Computing/
ls: : Authentication error

Note that there is no hard requirement that the target mount point be under /Volumes/Network; you can make the target mount point be /foo, and it will be created for you upon demand.

share|improve this answer
    
I find this a preferable solution over using Finder for two reasons: 1) it directly specifies the mounted share name and 2) takes fewer, easily automated, steps to add another share to the mix. For one or two share, Finder is barely acceptable (and only with an additional step to persist the setup) but for dozens of shares using Finder is tedious. OTOH, this solution is more 'unixy', a good thing. –  pmr Jun 17 '12 at 13:16
    
If you are trying to connect as guest, use the same steps, except that url is: cifs://guest:@192.168.0.200/music –  Jhonny Everson Sep 29 '12 at 4:52
    
Be careful making changes to fstab - I ended up having to enter recovery mode and revert my changes, as my system would hang immediately after login. You have been warned. –  Matt Nov 8 '12 at 21:46
2  
Is there a way to store passwords in system's keychain? I don't like to store my passwords inside clear text files. –  neon Oct 12 '13 at 13:42
add comment

Here's how can automount a network drive

  1. Connect to your network drive (finder > go > connect to server)

  2. Enter the credentials for your login to your network drive and tick the ‘remember in keychain’

  3. Open system settings > users > login items

  4. Drag the icon for your network drive from your desktop to the startup items.

Source: This article

share|improve this answer
3  
It works :) However if you don't like having Finder popping up every time you login, you could use Automator instead: apple.stackexchange.com/questions/18522/… –  wildpeaks May 24 '12 at 15:03
    
You can hide the Finder by selecting the checkbox next to the login item. –  Arne Aug 6 '13 at 17:43
    
Checking the Hide checkbox next to the Login Items does not hide the Finder… I ended up using the Automator script suggested above and that works. –  Toland H Jan 19 at 8:31
add comment

You can auto mount a share by dragging the mounted volume to your "Login Items" in User Accounts. That's how I do it and it's worked since 10.5.

Once caveat re SMB shares, is that with Lion the share will take about 30 seconds to mount at startup... this delay is new since Apple replaced SAMBA with their in-house implementation in Lion.

share|improve this answer
    
I am aware of this workaround, however it's not what I need. The disadvantage of this option is that 2 Finder windows open automatically (even if 'hide' option is checked). In 10.6 autofs worked, mounting my Samba network drives correctly to mount points at /Volumes/... –  cyppher Sep 20 '11 at 13:33
add comment

Answer: Can't do it. (OS X Lion 10.7.2)

I tried dragging mounted volumes into my "Login Items" but it just pops up an authentication error when I re-login. Yes, this used to work OK in Leopard, but after I upgraded to Lion, it stopped working.

Whenever I try to connect to my SMB shares using Finder, it gives me the same error.

I am able to mount SMB shares from the command-line, and they will also show up in Finder, once they're mounted, and Finder works just fine after that. So, as long as I go out to command-line to do the mounting, it's OK, but it won't work from "Login Items" or "Connect to Server"

share|improve this answer
1  
I'm going to upvote this because similar experience. Sucks. –  David Ryder Mar 11 '12 at 3:57
add comment

Use AppleScript:

In the AppleScript editor enter this:

tell application "Finder"

try

mount volume "cifs://server/share"

end try

end tell

The save the script as an application. Add to your Login StartUp items

share|improve this answer
add comment

protected by Community Apr 16 '12 at 23:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.