Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two HDs, in one there's a OS-less NTFS partition which I sucessfully shrunk using Linux's gparted utility. On the other drive, I have Windows 7, which since the resize, will only boot on one each four attempts if the former HD is turned on.

If it's turned off, it will always boot correctly.

When it doesn't boot, screen goes all black but the first row, where I can see some random blue pixels. Sometimes with control + alt + supr this screen disappears, proceeding to the login window.

On successful boots, the shrunk partition is fully recognised by Windows.

What is it exactly going on here and how can I solve this issue?

share|improve this question
In gparted check the flags on the partition. Maybe the non-bootable partition has its boot flag set. So when it is on the system attempts to boot from it. – Kevin Sep 17 '11 at 19:19
Will try it, in fact that partition used to be bootable! I deleted Windows XP off of it the 'dirty' way in order to preseve certain folders. – vemv Sep 17 '11 at 19:44
Unfortunately this didn't work :( the issue persists with the same exact characteristics. – vemv Sep 17 '11 at 21:27
What happens if you select the proper drive from the boot menu? Depending on the system this is usually brought up from pressing F9, f10, or F12. – Kevin Sep 17 '11 at 21:33
The proper drive was always chosen. Finally got to solve it, check my question if you're curious... thanks for the help anyway! – vemv Sep 17 '11 at 21:44

Remove the 2nd HD, boot into Windows and schedule a check of the 1st, weird acting hard drive. There might be a problem with it that can be repaired.

share|improve this answer
You mean to self-test (with chkdisk?) the Windows partition? – vemv Sep 17 '11 at 18:37

The 'issue' was that a long system-programmed chkdisk was running, but I couldn't know this because I marked No GUI Boot on msconfig; a buggy black screen displayed instead as I described in my question.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .