Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble installing libqt4-dev on Ubuntu Karmic. Here's the output:

The following packages have unmet dependencies:

  libqt4-core: Depends: libqtcore4 (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
               Depends: libqt4-network (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
               Depends: libqt4-script (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
               Depends: libqt4-xml (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
               Depends: libqt4-dbus (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
  libqt4-dev: Depends: libqt4-dbus (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-qt3support (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-xml (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqtcore4 (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqtgui4 (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-network (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-svg (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-webkit (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-sql (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-script (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-scripttools (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-xmlpatterns (= 4.5.3really4.5.2-0ubuntu1.1) but 4:4.7.0-0ubuntu2~lucid1~ppa2 is to be installed
              Depends: libqt4-designer (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-help (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-assistant (= 4.5.3really4.5.2-0ubuntu1.1) but it is not going to be installed
              Depends: libqt4-test (= 4.5.3really4.5.2-0ubuntu1.1) but 4:4.7.0-0ubuntu2~lucid1~ppa2 is to be installed
              Depends: qt4-qmake (= 4.5.3really4.5.2-0ubuntu1.1) but 4:4.7.0-0ubuntu2~lucid1~ppa2 is to be installed
  libqt4-test: Depends: libqtcore4 (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
  libqt4-xmlpatterns: Depends: libqt4-network (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed
                      Depends: libqtcore4 (= 4:4.7.0-0ubuntu2~lucid1~ppa2) but it is not going to be installed

I would really appreciate detailed instructions/suggestions.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.