Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I built this computer back in June and this has been an issue ever since I first built it. What happens is that my computer will POST just fine and then go to the black screen where it states "Loading Windows". Usually it sits there for a second and then it the pulsing Windows logo will appear, and after a few seconds, it brings me to the Windows login screen. However, about once a week at least, it will just sit there with a black screen and the "Loading Windows" text, but the logo will never appear. The hard drive indicator remains off and I don't hear any hard drive activity, which tells me that it's stuck. There's no error messages, but it never loads Windows. What I do here is just push the reset button and it will reboot. The "repair Windows" option never helps and is useless, so I just say "Load Windows normally", and it will load Windows fine 100% of the time, without fail. However, something must be wrong.

The computer started out with one 500GB hybrid SSD, and exhibited this behavior. I put in another and put it on RAID0 and it hasn't changed. It has 4 x 4GB of RAM, and a friend told me that perhaps the RAM is underpowered. So, every time this happens, I go into the BIOS and up the DRAM voltage one tick. I've been doing this for weeks and it hasn't done anything (first time I did it, I didn't see the issue for over a week, then it started happening again). I'm over 1.55V (I think 1.553V, if memory serves) but it's not even overclocked (they're 1333MHz) so I'm getting anxious that this won't solve the issue. I did both a full run of Memtest86+ and chkdsk and they both reported no errors. I've run several benchmarking suites (such as Heaven DX11 Benchmark, Crystal DiskMark, Furmark, 3DMark 11, and others, as well as playing games on high end settings and it never has given me any issues there, so it's not a hardware instability once Windows loads. I've even on one occasion had the computer up for a total of about 2 weeks straight and it didn't show any sign of glitching or malfunction.

This is the first computer I've built, and I am inexperienced with overclocking and dealing with power issues or other corner cases. Is my friend right that it's underpowered RAM? Or is there something else that could be afoot?

I have my computer specs below:

Computer:      MSI MS-7640
CPU:           AMD Phenom II X4 955 Black Edition (Deneb, RB-C3) @ 3200 MHz (16.00x200.0)
Motherboard:   MSI 890FXA-GD65 (MS-7640)
Chipset:       ATI RD890 + SB810/SB850
Memory:        16384 MBytes @ 666 MHz, 9.0-9-9-24
               - 4096 MB PC10600 DDR3 SDRAM - Patriot Memory (PDP Systems) PSD34G13332
               - 4096 MB PC10600 DDR3 SDRAM - Patriot Memory (PDP Systems) PSD34G13332
               - 4096 MB PC10600 DDR3 SDRAM - Patriot Memory (PDP Systems) PSD34G13332
               - 4096 MB PC10600 DDR3 SDRAM - Patriot Memory (PDP Systems) PSD34G13332
Graphics:      MSI R6970 (MS-V237)
               ATI RADEON HD 6970 (CAYMAN XT), 2048 MB GDDR5 SDRAM
Graphics:      MSI R6970 (MS-V237)
               ATI RADEON HD 6970 (CAYMAN XT), 0 MB 
Drive:         AMD 2+0 Stripe/RAID0, Disk drive
Drive:         ATAPI iHBS212   2, BD-RE
Drive:         ATAPI iHBS212   2, BD-RE
Drive:         AMD RAID Console, Processor
Sound:         ATI SB800/Hudson-1 - High Definition Audio Controller
Sound:         ATI Cayman/Antilles - High Definition Audio Controller
Sound:         ATI Cayman/Antilles - High Definition Audio Controller
Network:       RealTek Semiconductor RTL8168/8111 PCI-E Gigabit Ethernet NIC
Network:       Realtek PCIe GBE Family Controller
OS:            Microsoft Windows 7 Professional (x64) Build 7601

As a note, I've been recommended in chat to enable boot logging and see if anything shows up. I've done that just now, and will post the results whenever this occurs again, if there's anything of interest.

EDIT

I've enabled verbose booting and boot logging, but so far have not seen the issue reappear within the past week or so. I will update when I do see it happen.

EDIT #2 (11/25/2011)

Since I've enabled the boot logging (and reverted back to stock DRAM voltages), I haven't seen the issue reappear. I feel it's worth noting that I also, during this time, installed Windows 8 Developer Preview as a second OS, and have it dual-boot using the Windows 7 boot loader. Would this extra delay (10 seconds, currently) before it attempts to load Windows 7 have any effect on its success in booting Windows? Does it make sense that it might have been getting to the "Loading Windows" step too quickly? Could this be an instability in the power supply?

By the way, the power supply is a Thermaltake TPX-775M Toughpower XT 775W.

EDIT #3 (9/30/2011)

I removed the Windows 8 Dev Preview partition so that it went back to the normal boot process. This morning, it hung at boot again. Since I was using verbose boot, it hung at the black screen before it started loading drivers. After I reset the computer and got into Windows, checking ntbtlog.txt didn't show anything logged for the failed boot session. So it apparently just sits there before it even starts loading drivers.

I think after work today I'm going to start the process of checking each stick of RAM. I've put that off long enough.

EDIT #4 (10/21/2011)

A little while ago, I found that one of my external USB hard drives had several bad sectors. Eventually it was unreadable. Since Windows likes to scan USB drives on startup, could this have caused the issue? I haven't seen the hang for quite some time now, after I ran chkdsk on the drive (currently it remains powered off, as I was able to recover the data on it). This drive has been hooked up since I built the computer. Perhaps Windows was finding bad sectors and didn't know how to proceed, even though it's an external HDD?

share|improve this question
    
I think that something with hardware, maybe HDD is dying? –  Little Helper Sep 18 '11 at 6:45
    
@Robrok It's a brand new hard drive. Actually, two, now, in RAID0. I said above that I ran chkdsk and it came up clean, so I don't think that's the case. –  Ben Richards Sep 18 '11 at 6:53
    
Have you tried booting with verbose info on what Windows is doing (instead of the "Loading Windows" screen) until the issue recurs? If not, that will likely get you more info. Here's info on how: windows.microsoft.com/en-US/windows7/Using-System-Configuration –  Slartibartfast Sep 18 '11 at 7:06
    
@Slartibartfast I have not, though I suppose I should try that. I can't predict when it will behave this way, so I'm not in a debugging mindset until when it happens, so I never thought to try. :) I'll give that a go when i try booting it tomorrow. –  Ben Richards Sep 18 '11 at 7:11
1  
Yes, scanning external drives can hang the boot process. I've had situations with perfectly functioning internal and external disks, and it still hung unless I first disconnected the external drive. –  Ben Voigt Oct 21 '11 at 19:16

3 Answers 3

You may have already tried this but, as no one else has suggested it...

Disable ALL overclocking features and next update ALL the drivers you can - never use the versions that come on disk and take a look at the AMD website and your motherboard company.

As it is happening at such an early stage, I believe the most likely cause is a bad I/O driver, but, it could be anything.

and finally if this doesn't solve it, we have to go the old fashioned way and disconnecting everything you can in case it is some sort of conflict/issue with third party hardware.

share|improve this answer
    
I always try to keep my drivers as up to date as possible. I would have immediately thought it was the hard drive, but I switched over to the RAID driver I got off of MSI's website for my motherboard when I installed that and it didn't make a difference. I haven't seen it occur since it now is dual-booting, but it doesn't mean it won't happen. Maybe it is RAM? I didn't want to start pulling things out until I saw the error occur again. –  Ben Richards Sep 27 '11 at 0:17

First; if you're overclocking, you need to step back down a notch once you start having problems. If you are having problems at the default BIOS settings then you have a hardware problem.

Memtest although great, does not always report errors. Try testing by taking out one stick at a time. I've had to do this recently with a machine. It took me 4 months to figure out which stick it was (failure once every 2-4 weeks in my case). Once I replaced the defective chip I have had a solid machine since (about 6 months now...)

Note: chkdsk only checks the file system structure. It does not check the disk itself. Look to see if the manufactirer has a tool to test the disk. Typically they will provide a bootable ISO for this.

share|improve this answer
    
Thanks for the advice! Yes, it's at stock BIOS settings, no overclocking yet. I'll check the disk first and then try out the RAM. I really don't want to have to do that kind of RAM debugging. But, if it's what I have to do, I'll give it a go. –  Ben Richards Sep 19 '11 at 1:34
up vote 0 down vote accepted

One of my external USB hard drives apparently was failing. Some weeks ago I found I couldn't access it anymore, so I had to run chkdsk, and about 1/3 of the drive was bad sectors. I believe that Windows may have been hanging because it was running into them while scanning the drive at boot. Since recovering the data off the drive and powering it off, I have not experienced any issues with booting. It has been a couple months now, so I believe this resolved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.