Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Base system is Vista 64-bit running VirtualBox 4.1.2

The network in the Windows 8 32-bit version works correctly in this setup but Windows 8 64-bit does not. By "not working" I mean that Windows cannot see the network and its troubleshooter states "Windows did not detect a properly installed network adapter"

Here is what I did in VirtualBox for the 32-bit VM: (In Settings | Network | Adapter 1)

  • Attached to: Bridged Adapter
  • Name: Realtek PCIe GBE Family Controller
  • Adapter Type: Intel PRO/1000 MT Desktop (82540OEM)
  • Promiscuous Mode: Deny

This works, and I noticed that the "adapter type" dropdown is enabled so I could select another brand if so inclined.

For the 64-bit VM:

  • Attached to: Bridged Adapter
  • Name: Realtek PCIe GBE Family Controller
  • Adapter Type: PCnet-FAST III (Am79C973)
  • Promiscuous Mode: Deny

"Adapter Type" is fixed to this wrong value, and I suspect that is why Windows 8-64 doesn't think it has any network hardware installed.

Any ideas?

share|improve this question
1  
It is pre-beta software and bound to be full of all sorts of bugs that cannot be remedied. Also, they may not have included a 64bit driver for that particular network adapter. –  Moab Sep 18 '11 at 16:19

2 Answers 2

up vote 2 down vote accepted

You need to make sure the VM is shutdown before you can change the Network Adapter Type. Then it shouldn't be fixed anymore. That worked for me at least.

share|improve this answer

I think that I had screwed up the current state of VirtualBox and its VMs - when you rename a VM to something with a "?" in it all hell breaks loose as well.

Rebooting and restarting worked (essentially what Dr. Zebra says above so I'll mark that as the answer).

Also this VirtualBox forum topic is useful for similar issues

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.