Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to build Firefox and I get an error I need a the newest version of yasm, 1.0.1 and I only have 0.8.0.

I did the logical thing:

$ sudo apt-get upgrade yasm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Just to be sure I tried:

$ yasm --version
yasm 0.8.0.2194

I tried using the Synaptic GUI but it couldn't see any versions besides 0.8.0.

The yasm website says that there is a 1.0.1, how can I make apt-get see it?

share|improve this question

migrated from stackoverflow.com Sep 18 '11 at 19:48

This question came from our site for professional and enthusiast programmers.

    
Have you tried "sudo apt-get update" ? – entitledX Sep 18 '11 at 17:38
2  
If you are on Lucid, that's the latest version. Upgrade to Maverick or Natty, or find a backport. launchpad.net/ubuntu/+source/yasm – tripleee Sep 18 '11 at 19:46
    
Try updating ubuntu. – pbfy0 Aug 15 '12 at 20:54

You must log in to answer this question.