Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use only webbased Gmail for mail, but Mail.app keeps popping up as a result from iCal-appointments that have a e-mail reminder setting. I also get these reminders from Gmail anyway and I would like to disable the Mail.app program altogether.

I'm kind of fed up of doing "forcequit Mail.app" from Alfred several times a day. How can I solve this? Is there some kind of hook like "When Mail.app launches, kill it"? Mail.app cannot be removed from OSX.

share|improve this question
    
Very similar question: How do I make Mail.app quit after iCal sends an alert? –  slhck Sep 18 '11 at 20:49
    
GARR damn straight! latest osx is, like, constant annoying city! –  david van brink Dec 2 '12 at 2:11
add comment

8 Answers

up vote 49 down vote accepted

There's really only one way to kill Mail.app (as per my comment on waiwai's answer). Open Terminal.app from Applications/Utilities and enter:

sudo chmod 000 /Applications/Mail.app/Contents/MacOS/Mail

This will prompt you for your administrator password.

To reverse this, enter:

sudo chmod 755 /Applications/Mail.app/Contents/MacOS/Mail

I originally thought iCal was using the Launch Services database to open Mail, but in order to get the communication working, it relies upon AppleScript instead. You can find the script here:

/Applications/iCal.app/Contents/Resources/Mail.applescript

Unfortunately, it says:

… changes to this file will not be reflected in iCal behavior unless manually recompiled.

Thus you can't just delete or move away this file. You won't see any difference.

share|improve this answer
add comment

For those with Mountain Lion, you can try this: http://www.quora.com/OS-X-10-8-Mountain-Lion/Is-there-a-way-to-completely-disable-OS-X-Mail-app-to-fire-up-and-send-Calendar-notifications

In Calendar.app, click Calendars to show your calendars in the left sidebar. Then right-click the calendar in question, choose Get Info, then click Ignore alerts. This way you'll continue to receive your Google Calendar email alerts, but not the additional OS X Calendar alerts.

share|improve this answer
    
Excellent. After upgrading to Mountain Lion, I was confused as to why I was receiving e-mails from both Google Calendar and myself for the same events. Thanks! –  jrhorn424 Mar 3 '13 at 20:57
add comment

I renamed /Applications/Mail.app to /Applications/Mail.disabled using the following command in Terminal:

sudo mv /Applications/Mail.app /Applications/Mail.disabled
share|improve this answer
2  
This wasn't a complete solution, as OSX started asking where Mail.app was. So 'sudo chmod 000 /Applications/Mail.app/Contents/MacOS/Mail' is the solution that works best. –  Michiel Borkent Sep 19 '11 at 7:59
    
Renaming mail didn't work for me. They must have figured out people were doing that. I'm on 10.7.3. –  user4649 Feb 24 '12 at 19:52
add comment

This is happening because Google calendar is trying tho send the email notification. If you don't need the email notification but an alarm is enough you can just adjust settings in Google calendar to not send email notifications and it will stop trying to start Mail.app every time you have an appointment coming.

share|improve this answer
add comment

For complete Mail.app killage (and not just changing default mail app), open Terminal (inside /Applications/Utilities in an administrative account and enter

sudo chmod 000 /Applications/Mail.app

It will prompt you for your password. Enter it, and then try to open Mail. It won't open!

To undo:

sudo chmod 755 /Applications/Mail.app

(If using Terminal, then you could also remove the app too, I guess, but I'd suggest just chmodding it in case you need it in a year's time.)

share|improve this answer
    
Thanks for the suggestion! I've added that to my answer. –  waiwai933 Sep 18 '11 at 21:00
    
Tried this, but I could still launch mail after doing this. Weird. But I solved it like this, using the Terminal: sudo mv /Applications/Mail.app /Applications/Mail.disabled. If I want Mail.app back, I'll just rename it back. –  Michiel Borkent Sep 18 '11 at 21:12
3  
Ah, well of course that won't really work, because the real binary /Applications/Mail.app/Contents/MacOS/Mail is still executable. So use the chmod command on this, not the Mail.app folder. @MichielBorkent –  slhck Sep 18 '11 at 21:19
add comment

Wouldn't it work to just disable all alerts in iCal, so that it never tries to send an alert via Mail?

In iCal preferences, click on Advanced, then click on "Disable all Alerts".

This leaves Mail executable in case you ever want to use it for another purpose (like looking at locally archived email).

share|improve this answer
    
If you disable all alerts, you won't get the popup alert either. –  Marc Aug 1 '12 at 17:23
add comment

Highlight "Mail" in applications folder. "Command I" or "get info" from file menu. At bottom in "sharing and permissions" you must unlock, then highlight the user, and click the "minus" sign below. This places a tiny red minus sign on the Mail folder and disables it

share|improve this answer
    
Per the comment on waiwai's answer, this only disables the .app folder, not the actual application, so it wouldn't work. Are you sure it works for you? –  slhck Jan 20 '13 at 16:29
add comment

Open Mail.app, then open the preferences. On the General pane set the "Default Email Reader" to whatever you actually use (like Firefox.app). Mail.app will stop opening then!

share|improve this answer
    
I tried this several times, with several apps, but Mail just kept popping up. –  Michiel Borkent Sep 18 '11 at 20:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.