Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a Mac (OS X) in clamshell mode with a Windows USB keyboard attached.

A known issue is that the alt and command keys are swapped on the Windows keyboard. Namely, by default, the Windows key is command and it is in the "wrong" place.

In System Preferences -> Keyboard -> Keyboard -> Modifier Keys... one can redefine this, and have the USB keyboard with the same order of alt+command keys.

However, my problem is how to save/keep this setting. In particular, once I disconnect-reconnect my keyboard, I have to redefine the setting. Is there a way to save this?

share|improve this question

closed as too localized by Sathya Sep 21 '11 at 8:49

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Closed as per OP's request - The problem didn't happen again (regardless of this thread). I think this question has to be removed. I cannot mark an answer as excepted since I didn't have, eventually, to try the suggested solution –  Sathya Sep 21 '11 at 8:50
add comment

1 Answer

Apparently there is a program called DoubleCommand that does what you want. From this blog:

DoubleCommand is software for Mac OS X (a kernel extension) that lets you remap keys, in other words change the way your keyboard works. Often used to make a PC keyboard more comfortable with a Mac, swapping the Alt (Option) and Windows (Command or Apple) keys

I found this searching for 'mac remap keys keyboard' on Google, did you not find this?

share|improve this answer
    
I found it, but I was hopping I can solve the issue without a 3rd party tool. Actually, as I mentioned, I solved it within the OS X, the only issue is that the system doesn't remember my preferences with the USB keyboard... In case there will be no solution, I will try this tool - but it's a second option for me. –  Dror Sep 19 '11 at 7:36
    
I see. There are probably some system files that influence this behaviour, the trouble is finding which. Perhaps using DoubleCommand you can find these files (lsof) and change them manually? Or uninstall the tool once you're done. –  Tim Sep 19 '11 at 10:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.